x11-misc/yabar: new package
authorJake Lilly <lillyjsm@gmail.com>
Fri, 19 Jul 2019 03:46:08 +0000 (23:46 -0400)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 1 Aug 2019 13:01:30 +0000 (16:01 +0300)
A modern and lightweight status bar for X window managers

Bug: https://bugs.gentoo.org/658102
Signed-off-by: Jake Lilly <lillyjsm@gmail.com>
Package-Manager: Portage-2.3.66, Repoman-2.3.11
Closes: https://github.com/gentoo/gentoo/pull/12471
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
x11-misc/yabar/Manifest [new file with mode: 0644]
x11-misc/yabar/metadata.xml [new file with mode: 0644]
x11-misc/yabar/yabar-0.4.0_p20190316.ebuild [new file with mode: 0644]

diff --git a/x11-misc/yabar/Manifest b/x11-misc/yabar/Manifest
new file mode 100644 (file)
index 0000000..64629c0
--- /dev/null
@@ -0,0 +1 @@
+DIST yabar-0.4.0_p20190316.tar.gz 892725 BLAKE2B eb14b06327533034756885c68ab03b1ff049c987d1dac6d083c553646cd178210429d9457c1067db3211fcb39e9814a260aed201dea4e6410544b9247c5dee93 SHA512 f93250605c5b56d64c7ec6a7e7faa6120cdc06191ddafb13822875fd98b1b7a1822d9b93b62c49c302b1d4bffb14a200feed937efb0b11711de7159ce83eb7c5
diff --git a/x11-misc/yabar/metadata.xml b/x11-misc/yabar/metadata.xml
new file mode 100644 (file)
index 0000000..e6d7b0c
--- /dev/null
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>lillyjsm@gmail.com</email>
+               <name>Jake Lilly</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <use>
+               <flag name="playerctl">
+                       Uses <pkg>media-sound/playerctl</pkg> to retrieve the name of the currently 
+                       played song
+               </flag>
+       </use>
+       <upstream>
+               <remote-id type="github">geommer/yabar</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/x11-misc/yabar/yabar-0.4.0_p20190316.ebuild b/x11-misc/yabar/yabar-0.4.0_p20190316.ebuild
new file mode 100644 (file)
index 0000000..b9fe190
--- /dev/null
@@ -0,0 +1,61 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT="a0d3fdfed992149b741eb8fcf53f02b5d1a6142e"
+DESCRIPTION="A modern and lightweight status bar for X window managers"
+HOMEPAGE="https://github.com/geommer/yabar"
+SRC_URI="https://github.com/geommer/yabar/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="playerctl"
+
+DEPEND="
+       app-text/asciidoc
+       dev-libs/libconfig:=
+       media-libs/alsa-lib
+       net-wireless/wireless-tools
+       x11-libs/cairo[xcb]
+       x11-libs/gdk-pixbuf:2
+       x11-libs/libxkbcommon[X]
+       x11-libs/pango
+       x11-libs/xcb-util-wm
+       playerctl? ( media-sound/playerctl )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+       default
+       # Respect CFLAGS and LDFLAGS
+       # Declare VERSION without relying on git
+       # Replace playerctl dependency option with basename
+       sed -i -e "s:-flto -O2::g" -e "s:-Wall::" \
+       -e "s:\$(shell git describe):0.4.0-179-ga0d3fdf:" \
+       -e "s:^DEPS += playerctl-1.0:DEPS += playerctl:" \
+       Makefile || die "Failed to update Makefile"
+}
+
+src_compile() {
+       if use playerctl; then
+               emake PLAYERCTL=1
+       else
+               emake
+       fi
+}
+
+src_install() {
+       default
+       docinto examples
+       dodoc examples/example.config
+       docompress -x "/usr/share/doc/${PF}/examples"
+}
+
+pkg_postinst() {
+       elog "An example yabar configuration file can be found in"
+       elog "the following path: /usr/share/doc/${PF}/examples"
+}