www-server/sniproxy: bump to 0.6.0
authorPierre-Olivier Mercier <nemunaire@nemunai.re>
Mon, 10 Dec 2018 12:49:53 +0000 (13:49 +0100)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 31 Jan 2019 17:36:39 +0000 (09:36 -0800)
Closes: https://bugs.gentoo.org/651928
Closes: https://github.com/gentoo/gentoo/pull/10604
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re>
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
www-servers/sniproxy/Manifest
www-servers/sniproxy/sniproxy-0.6.0.ebuild [new file with mode: 0644]

index 3f149dfd37511284d25b1f89d10fa0d922134ea7..14bb5bf4900cd4c02bc2adf8abf4d0d4101257d5 100644 (file)
@@ -1 +1,2 @@
 DIST sniproxy-0.5.0.tar.gz 72654 BLAKE2B 11f2a66af0d5a19807178687b2a5044aa0cca18a9586c60a6e15604b90f4c32d16d9ac8d037df2cafe57a2dc3a576e1ff72b8f58b59e6822d2a45520b9c770f4 SHA512 52dbb217193d2b7bf9dea37b13fde395b5c56d0a6627508a245f2807920deb282aae3c1ae7e6b5fa68432990e48998989fd28027b65cb7310f214b29f98e5e5d
+DIST sniproxy-0.6.0.tar.gz 78515 BLAKE2B 1ac8decc793e7b3d73d833bc392b3ef035bd2ba7d515c54ff46de16ee8897c0c5392929d5c7a22a131c1f017897cc6f8e9c50aff8164e4afbdc23155b804b613 SHA512 8a99573673bdd57e528c5781cb166d39c80daed699382b24c3fa18a6011d074a1d9e470fee404d24b4450cf067c9995125910b2941b5216d88d189a1d79ebf73
diff --git a/www-servers/sniproxy/sniproxy-0.6.0.ebuild b/www-servers/sniproxy/sniproxy-0.6.0.ebuild
new file mode 100644 (file)
index 0000000..2c4947f
--- /dev/null
@@ -0,0 +1,82 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools user
+
+if [[ ${PV} == 9999* ]]; then
+       EGIT_REPO_URI="https://github.com/dlundquist/sniproxy.git"
+       EGIT_BRANCH="master"
+       inherit git-r3
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/dlundquist/sniproxy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Proxies incoming HTTP and TLS connections based on the hostname"
+HOMEPAGE="https://github.com/dlundquist/sniproxy"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="+dns +largefile rfc3339 test"
+
+RDEPEND="
+       dev-libs/libev
+       >=dev-libs/libpcre-3
+       dns? ( net-libs/udns )
+"
+BDEPEND="
+       ${RDEPEND}
+       sys-devel/gettext
+       virtual/pkgconfig
+"
+DEPEND="
+       test? ( net-misc/curl )
+"
+
+src_prepare() {
+       default
+       eautoreconf
+
+       sed -i "/user/s/daemon/sniproxy/" debian/sniproxy.conf || die "Unable to replace configuration"
+       sed -i "/create/s/daemon/sniproxy/" debian/logrotate.conf || die "Unable to replace logrotate configuration"
+}
+
+src_configure() {
+       local my_conf=(
+               $(use_enable dns)
+               $(use_enable largefile)
+               $(use_enable rfc3339 rfc3339-timestamps)
+       )
+
+       econf "${my_conf[@]}"
+}
+
+src_install() {
+       default
+
+       newinitd "${FILESDIR}/sniproxy.init" sniproxy
+
+       insinto /etc/sniproxy
+       doins debian/sniproxy.conf
+
+       keepdir /var/log/sniproxy
+
+       insinto /etc/logrotate.d
+       newins debian/logrotate.conf sniproxy
+
+       dodoc ARCHITECTURE.md AUTHORS README.md
+       doman man/sniproxy.8
+       doman man/sniproxy.conf.5
+}
+
+src_test() {
+       emake -j1 check
+}
+
+pkg_postinst() {
+       enewgroup "${PN}"
+       enewuser "${PN}" -1 -1 /var/lib/sniproxy "${PN}"
+}