dev-python/doublex: Drop unnecessary die
authorJustin Lecher <jlec@gentoo.org>
Fri, 11 Sep 2015 07:01:09 +0000 (09:01 +0200)
committerJustin Lecher <jlec@gentoo.org>
Fri, 11 Sep 2015 07:53:15 +0000 (09:53 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/doublex/doublex-1.7.ebuild
dev-python/doublex/doublex-1.8.1.ebuild

index 414cc621dbff828f447d161f0c96ff0028739691..4fbe1c86fad32cf6b134de0be7dcc3812abb60b6 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
+
 PYTHON_COMPAT=( python2_7 )
 
 inherit distutils-r1
@@ -25,11 +26,11 @@ DEPEND="
 RDEPEND=""
 
 python_test() {
-       esetup.py test || die "Tests failed under ${EPYTHON}"
+       esetup.py test
 }
 
 python_install_all() {
        distutils-r1_python_install_all
 
-       rm "${D}"/usr/README.rst || die "Couldn't remove spurious README.rst"
+       rm "${ED}"/usr/README.rst || die "Couldn't remove spurious README.rst"
 }
index 84fe635528c57a3b0606355b8836394b9e63a832..d803de866df796a0bb4b84cff062e7b597d52887 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
+
 PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
 
 inherit distutils-r1 vcs-snapshot
@@ -32,7 +33,7 @@ python_compile_all() {
 }
 
 python_test() {
-       esetup.py test || die "Tests failed under ${EPYTHON}"
+       esetup.py test
 }
 
 python_install_all() {
@@ -40,5 +41,5 @@ python_install_all() {
 
        distutils-r1_python_install_all
 
-       rm "${D}"/usr/README.rst || die "Couldn't remove spurious README.rst"
+       rm "${ED}"/usr/README.rst || die "Couldn't remove spurious README.rst"
 }