app-portage/eix: Fix sourced file paths
authorMichał Górny <mgorny@gentoo.org>
Sun, 15 Dec 2019 12:54:34 +0000 (13:54 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 15 Dec 2019 13:00:04 +0000 (14:00 +0100)
Fix sourced file paths to use EPREFIX rather than EROOT.  ROOT is meant
to be only temporary, and used only in pkg_*inst/*rm.

The revbump also covers propagating earlier fix to missing slash
in the ebuild.

Closes: https://bugs.gentoo.org/702814
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/eix/eix-0.33.9-r1.ebuild [moved from app-portage/eix/eix-0.33.9.ebuild with 90% similarity]

similarity index 90%
rename from app-portage/eix/eix-0.33.9.ebuild
rename to app-portage/eix/eix-0.33.9-r1.ebuild
index 2c0ec5f0a0bcbb6f378ff3224f23aff6273ab7af..79b4f2b3dc894f4456eda943cc93a0e9e4f1a555 100644 (file)
@@ -35,10 +35,10 @@ src_prepare() {
        default
        sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
 
-       sed -e "/eixf_source=/s:push.sh:cat \"${EROOT}/usr/share/push/push.sh\":" \
-               -e "/eixf_source=/s:quoter_pipe.sh:cat \"${EROOT}/usr/share/quoter/quoter_pipe.sh\":" \
+       sed -e "/eixf_source=/s:push.sh:cat \"${EPREFIX}/usr/share/push/push.sh\":" \
+               -e "/eixf_source=/s:quoter_pipe.sh:cat \"${EPREFIX}/usr/share/quoter/quoter_pipe.sh\":" \
                -i src/eix-functions.sh.in || die
-       sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EROOT}/usr/share/eix/eix-functions\\\\\":" \
+       sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EPREFIX}/usr/share/eix/eix-functions\\\\\":" \
                -i src/Makefile.am || die
        eautoreconf
 }