games-fps/tribes2: EAPI=5; tidy
authorMichael Sterrett <mr_bones_@gentoo.org>
Sat, 2 Jan 2016 08:05:47 +0000 (03:05 -0500)
committerMichael Sterrett <mr_bones_@gentoo.org>
Sat, 2 Jan 2016 08:05:47 +0000 (03:05 -0500)
Package-Manager: portage-2.2.24

games-fps/tribes2/tribes2-25034.ebuild

index aba5b65b0a1bc1c6dffb38278e07b98ce3dac0aa..2bcad311f4f8cc9a81bc5fb1f0b4d6aecd52d813 100644 (file)
@@ -2,9 +2,9 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
+EAPI=5
 inherit eutils unpacker cdrom games
 
-IUSE=""
 DESCRIPTION="Tribes 2 - Team Combat on an Epic Scale"
 HOMEPAGE="http://www.lokigames.com/products/tribes2/"
 SRC_URI="http://www.libsdl.org/projects/${PN}/release/${P}-cdrom-x86.run
@@ -16,6 +16,7 @@ SLOT="0"
 # time to try to figure it out but this definitely needs to stay -amd64 until
 # someone does fix the patching.
 KEYWORDS="-amd64 x86"
+IUSE=""
 RESTRICT="mirror strip"
 
 DEPEND="sys-libs/glibc
@@ -41,26 +42,26 @@ src_unpack() {
 src_install() {
        einfo "Copying files... this may take a while..."
        exeinto "${dir}"
-       doexe "${CDROM_ROOT}"/bin/x86/glibc-2.1/{t2launch,tribes2,tribes2.dynamic,tribes2d,tribes2d-restart.sh,tribes2d.dynamic} || die "doexe failed"
+       doexe "${CDROM_ROOT}"/bin/x86/glibc-2.1/{t2launch,tribes2,tribes2.dynamic,tribes2d,tribes2d-restart.sh,tribes2d.dynamic}
 
        insinto "${dir}"
-       doins "${CDROM_ROOT}"/{README,README.tribes2d,Tribes2_Manual.pdf,console_start.cs,kver.pub} "${Ddir}" || die "copy failed"
+       doins "${CDROM_ROOT}"/{README,README.tribes2d,Tribes2_Manual.pdf,console_start.cs,kver.pub} "${Ddir}"
 
        # Video card profiles
        # TODO: move this to src_unpack where it belongs.
-       tar xzf ${CDROM_ROOT}/profiles.tar.gz -C "${Ddir}" || die "uncompressing profiles"
+       tar xzf ${CDROM_ROOT}/profiles.tar.gz -C "${Ddir}" || die
 
        # Base (Music, Textures, Maps, etc.)
-       doins -r ${CDROM_ROOT}/base ${CDROM_ROOT}/menu || die "copying data"
+       doins -r ${CDROM_ROOT}/base ${CDROM_ROOT}/menu
 
        cd "${S}"
        loki_patch --verify patch.dat
-       loki_patch patch.dat "${Ddir}" >& /dev/null || die "patching"
+       loki_patch patch.dat "${Ddir}" >& /dev/null || die
 
        # now, since these files are coming off a cd, the times/sizes/md5sums wont
        # be different ... that means portage will try to unmerge some files (!)
        # we run touch on ${D} so as to make sure portage doesnt do any such thing
-       find "${Ddir}" -exec touch '{}' \;
+       find "${Ddir}" -exec touch '{}' +
 
        newicon "${CDROM_ROOT}"/icon.xpm tribes2.xpm
        games_make_wrapper t2launch ./t2launch "${dir}" "${dir}"