Adding support for linking against libnids and libpcap wrt bug #150212 thanks to...
authorMarkus Ullmann <jokey@gentoo.org>
Sun, 8 Oct 2006 12:57:20 +0000 (12:57 +0000)
committerMarkus Ullmann <jokey@gentoo.org>
Sun, 8 Oct 2006 12:57:20 +0000 (12:57 +0000)
Package-Manager: portage-2.1.2_pre2-r6

net-analyzer/scanlogd/ChangeLog
net-analyzer/scanlogd/files/digest-scanlogd-2.2.6-r2 [new file with mode: 0644]
net-analyzer/scanlogd/scanlogd-2.2.6-r2.ebuild [new file with mode: 0644]

index 7ddbd478fbae69d37d6a69124308146f13985087..3632102db6827f3657251bd59e10959c1f5da5c6 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for net-analyzer/scanlogd
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scanlogd/ChangeLog,v 1.20 2006/10/08 12:43:24 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scanlogd/ChangeLog,v 1.21 2006/10/08 12:57:20 jokey Exp $
+
+*scanlogd-2.2.6-r2 (08 Oct 2006)
+
+  08 Oct 2006; Markus Ullmann <jokey@gentoo.org> -scanlogd-2.2.5.ebuild,
+  -scanlogd-2.2.6.ebuild, +scanlogd-2.2.6-r2.ebuild:
+  Adding support for linking against libnids and libpcap wrt bug #150212
+  thanks to Cedric Krier and small cleanup
 
   08 Oct 2006; Markus Ullmann <jokey@gentoo.org> scanlogd-2.2.6-r1.ebuild:
   Fixing prestripped binary issue in bug #147917
diff --git a/net-analyzer/scanlogd/files/digest-scanlogd-2.2.6-r2 b/net-analyzer/scanlogd/files/digest-scanlogd-2.2.6-r2
new file mode 100644 (file)
index 0000000..6d88874
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 7b8187ea718ebe47f22805b921b909ab scanlogd-2.2.6.tar.gz 10975
+RMD160 29b1df23c8a44b2d98e12fb2cfe8fe6127566b6f scanlogd-2.2.6.tar.gz 10975
+SHA256 4a2621037270f88576c8770261c53761edc875984f126872c880c2a98a8f63fa scanlogd-2.2.6.tar.gz 10975
diff --git a/net-analyzer/scanlogd/scanlogd-2.2.6-r2.ebuild b/net-analyzer/scanlogd/scanlogd-2.2.6-r2.ebuild
new file mode 100644 (file)
index 0000000..461da03
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scanlogd/scanlogd-2.2.6-r2.ebuild,v 1.1 2006/10/08 12:57:20 jokey Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Scanlogd - detects and logs TCP port scans"
+SRC_URI="http://www.openwall.com/scanlogd/${P}.tar.gz"
+HOMEPAGE="http://www.openwall.com/scanlogd/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nids pcap"
+
+DEPEND="nids? ( net-libs/libnids
+       net-libs/libnet
+       net-libs/libpcap )
+       pcap? ( net-libs/libpcap )"
+RDEPEND=${DEPEND}
+
+pkg_setup() {
+       enewgroup scanlogd
+       enewuser scanlogd -1 -1 /dev/null scanlogd
+       if use nids && use pcap ; then
+               ewarn
+               ewarn "As you set both nids and pcap useflag, we default to pcap"
+               ewarn
+       fi
+}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}/${P}-Makefile.patch"
+}
+
+src_compile() {
+       local target=linux
+       use nids && target=libnids
+       use pcap && target=libpcap
+
+       einfo "Compiling against ${target}"
+
+       emake CC="$(tc-getCC)" ${target} || die "emake failed"
+}
+
+src_install() {
+       dosbin scanlogd
+       doman scanlogd.8
+       newinitd "${FILESDIR}"/scanlogd.rc scanlogd
+}
+
+pkg_postinst() {
+       einfo "You can start the scanlogd monitoring program at boot by running"
+       einfo "rc-update add scanlogd default"
+}