sys-block/blktrace: avoid 'gcc' call in 'make install'
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 24 May 2020 22:17:28 +0000 (23:17 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 24 May 2020 22:17:28 +0000 (23:17 +0100)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-block/blktrace/blktrace-1.2.0.ebuild

index 68ca8627f8c1499d35097f29fe2a4a655352016d..099c1255badb432420aa851f7d4dab364d90caf2 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -47,7 +47,7 @@ src_compile() {
 }
 
 src_install() {
-       emake install DESTDIR="${ED}" prefix="/usr" mandir="/usr/share/man"
+       emake install CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${CPPFLAGS}" DESTDIR="${ED}" prefix="/usr" mandir="/usr/share/man"
        einstalldocs
        use doc && dodoc doc/blktrace.pdf btt/doc/btt.pdf
 }