dev-python/pyopenssl: version bump to 17.3.0
authorTim Harder <radhermit@gentoo.org>
Sun, 8 Oct 2017 16:50:44 +0000 (11:50 -0500)
committerTim Harder <radhermit@gentoo.org>
Sun, 8 Oct 2017 16:53:13 +0000 (11:53 -0500)
Closes: https://bugs.gentoo.org/633340

dev-python/pyopenssl/Manifest
dev-python/pyopenssl/pyopenssl-17.3.0.ebuild [new file with mode: 0644]

index 80d23bd0d5b4b95ecf092768a41d40148f3c7d91..2558e91e7ff52ab77597fb6e8bc820bdf993861c 100644 (file)
@@ -2,3 +2,4 @@ DIST pyOpenSSL-0.15.1.tar.gz 149887 SHA256 f0a26070d6db0881de8bcc7846934b7c3c930
 DIST pyOpenSSL-16.2.0.tar.gz 167305 SHA256 7779a3bbb74e79db234af6a08775568c6769b5821faecf6e2f4143edb227516e SHA512 c1b068137a492564fe958603712d401b7ee0def94c01a28be55f5c89e07c25684ecb0f465f3c56f35924bde038894f2914ac49539144845fb586d12b80307078 WHIRLPOOL 60f2fe38ba773ed52bcfe88da57bd78f2114d7018a6184ec1c0fa2a8ae6dab4cf2495cd2aa75d7a5b2beee49477dbb6b4256034cec83752db0a3c7e5f7c4debb
 DIST pyOpenSSL-17.0.0.tar.gz 167121 SHA256 48abfe9d2bb8eb8d8947c8452b0223b7b1be2383b332f3b4f248fe59ef0bafdd SHA512 819be95f920a70b40ae48ed6740bd1d8cd3bf2fc080f682db8978946929994cb87ac467e220267dcdafc40aa7ed2cce51a334a49b06c1e2665d295157181ddad WHIRLPOOL 8256ad13d35d7c7d1678bd6c35140e13a1f601f149bc38633b3f04eaec7e302853abcb5df857a04fd04dc8ac3feeb35d4247dc979cee0969dafc538ec9b70d5c
 DIST pyOpenSSL-17.2.0.tar.gz 170816 SHA256 5d617ce36b07c51f330aa63b83bf7f25c40a0e95958876d54d1982f8c91b4834 SHA512 aef1628665353445760a0c869c5b88ba1f61a3ade7471bfd1ad9e57672573501574dab5a2491aaac1dc283893fcac1a81dd9b972f43d53fe7ef1aa48e3f0e88a WHIRLPOOL aab3617e825237032efa44d5b89603bcd6b33095f76bb04b53140138066d9c6e96b64bb6def4425b3cf3aa279691142c66bf5c6b9a89ef5e5c64eb83459dc5a9
+DIST pyOpenSSL-17.3.0.tar.gz 168119 SHA256 29630b9064a82e04d8242ea01d7c93d70ec320f5e3ed48e95fcabc6b1d0f6c76 SHA512 2b58a652b8d6e2adadbc620a6b3411cd44169940ef1839fd3365cd343ebe1e630ddbb580d8d4dc79e738e0b4f91db0bdbbaecf18aea74204499c737eebb3fae8 WHIRLPOOL 154cb8beedd57c24aced9c0a37b2395a9c25a0696b803c70d40bc4df98802587e73602c7c74aebd03c60dd54849c293eede1366c0b2f5ccb0967331235754bc0
diff --git a/dev-python/pyopenssl/pyopenssl-17.3.0.ebuild b/dev-python/pyopenssl/pyopenssl-17.3.0.ebuild
new file mode 100644 (file)
index 0000000..d873a6b
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN=pyOpenSSL
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="
+       http://pyopenssl.sourceforge.net/
+       https://launchpad.net/pyopenssl
+       https://pypi.python.org/pypi/pyOpenSSL
+"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="
+       >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+       >=dev-python/cryptography-1.9[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+       )
+       test? (
+               virtual/python-cffi[${PYTHON_USEDEP}]
+               dev-python/flaky[${PYTHON_USEDEP}]
+               dev-python/pretend[${PYTHON_USEDEP}]
+               >=dev-python/pytest-3.0.1[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+       # Requires network access
+       sed -i -e 's/test_set_default_verify_paths/_&/' tests/test_ssl.py || die
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && emake -C doc html
+}
+
+python_test() {
+       # FIXME: for some reason, no-ops on PyPy
+       py.test -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( doc/_build/html/. )
+       if use examples ; then
+               docinto examples
+               dodoc -r examples/*
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+
+       distutils-r1_python_install_all
+}