dev-util/pkgconf: bump to 1.5.1
authorMike Gilbert <floppym@gentoo.org>
Sat, 7 Jul 2018 16:59:01 +0000 (12:59 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sat, 7 Jul 2018 16:59:01 +0000 (12:59 -0400)
Package-Manager: Portage-2.3.40_p15, Repoman-2.3.9_p247

dev-util/pkgconf/Manifest
dev-util/pkgconf/pkgconf-1.5.1.ebuild [new file with mode: 0644]
dev-util/pkgconf/pkgconf-9999.ebuild

index 3aee28f3f18b1e7f0bf55ef8be1dfa71bd9f139d..f51ab9afa17c3d437a8440bb9fabacb2a6f4f1d9 100644 (file)
@@ -2,3 +2,4 @@ DIST pkgconf-1.3.10.tar.xz 272704 BLAKE2B 7d39a17ba100818eecb64acc46d7000a5d7ecb
 DIST pkgconf-1.3.7.tar.xz 271840 BLAKE2B f4bb44e92ef2903a5962c85e0d4a939adf035c5e92fbd1d8a50d4022507d1f442e459849b537cc2b648c7a1bb5eac33aabf8a46d8b0df8794514596adee9888d SHA512 6c06afc4fe64c94a833db98d4dc7881192d38cc28eb1fb86345f4ce065489930ac953aa9f6b2df172127244cb1cbab1c85a042aa0f6be4fa18bf9dcd83173960
 DIST pkgconf-1.3.90.tar.xz 285036 BLAKE2B e56e3ea3a6552ff190f239bf4d8d7e3d63c0ecc6a771d0a7c33aeacf6da61190abfed1ac2268d28d64efc298bc4b2b3f032eeaf8b2be628bef1d12de4b1aec36 SHA512 8efca947546969fea63e97f23eb1b5af49a1f2378eec66ff4f403fa218bcb3d5fed62a32fd6be70d9ebf39c8024bb9714cd0c2a52e6960c98021cabefc274530
 DIST pkgconf-1.4.2.tar.xz 285548 BLAKE2B ad48bac309e90f2c2958ee19ebbf95ec90c55ebd98a44486f47cc403b8c193131377433a23f16adb64bf97832ff5a0c20e0a3d01da5c6adb2b70483dcf23b9cf SHA512 d9d3bfc7ddc3ceda65f7ad11b1a3c8a48aee0b5ac135aeb54b41091ca1ef0d9a5cda4a5c1ba2470ec12ce870a361eeddd802243eda3c2e2c0f2be3e7fe0ca236
+DIST pkgconf-1.5.1.tar.xz 289616 BLAKE2B 32cd7b3440635cacbc197ac6163c2d0c0a57281d060e27ba097f7845636e41160c25092f42e3d3dacacc0d9f01f6d3468ffaa2a18a82f98ce5fdc8e9f7267137 SHA512 a2e7a675fed6600fd38d90a98fa8295e1b79b4dd018f544ca777caf8cf6687029d0925ef33a08dd7815d5d3cad835bb9b70ab3161b6e083965fa60652661955a
diff --git a/dev-util/pkgconf/pkgconf-1.5.1.ebuild b/dev-util/pkgconf/pkgconf-1.5.1.ebuild
new file mode 100644 (file)
index 0000000..1ae23ee
--- /dev/null
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+       inherit autotools git-r3
+else
+       SRC_URI="https://distfiles.dereferenced.org/${PN}/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+inherit multilib-minimal
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://github.com/pkgconf/pkgconf"
+
+LICENSE="BSD-1"
+SLOT="0/3"
+IUSE="+pkg-config test"
+
+# tests require 'kyua'
+RESTRICT="!test? ( test )"
+
+DEPEND="
+       test? (
+               dev-libs/atf
+               dev-util/kyua
+       )
+"
+RDEPEND="
+       pkg-config? (
+               !dev-util/pkgconfig
+               !dev-util/pkg-config-lite
+               !dev-util/pkgconfig-openbsd[pkg-config]
+       )
+"
+
+MULTILIB_CHOST_TOOLS=(
+       /usr/bin/pkgconf
+)
+
+src_prepare() {
+       default
+
+       [[ ${PV} == "9999" ]] && eautoreconf
+       if use pkg-config; then
+               MULTILIB_CHOST_TOOLS+=(
+                       /usr/bin/pkg-config
+               )
+       fi
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE=${S} econf
+}
+
+multilib_src_test() {
+       unset PKG_CONFIG_LIBDIR PKG_CONFIG_PATH
+       default
+}
+
+multilib_src_install() {
+       default
+
+       if use pkg-config; then
+               dosym pkgconf /usr/bin/pkg-config
+       else
+               rm "${ED%/}"/usr/share/aclocal/pkg.m4 || die
+       fi
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       find "${ED}" -name '*.la' -delete || die
+}
index e2b768e8e57296dedafac6b3b0d87552b1f0cf8d..1ae23ee0c0d378f97098b230087c61111e7fe8fc 100644 (file)
@@ -56,6 +56,11 @@ multilib_src_configure() {
        ECONF_SOURCE=${S} econf
 }
 
+multilib_src_test() {
+       unset PKG_CONFIG_LIBDIR PKG_CONFIG_PATH
+       default
+}
+
 multilib_src_install() {
        default