app-crypt/acme: certbot* too, 0.34.2 cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 12 Jul 2019 18:57:58 +0000 (13:57 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 12 Jul 2019 18:59:02 +0000 (13:59 -0500)
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-crypt/acme/Manifest
app-crypt/acme/acme-0.34.2.ebuild [deleted file]
app-crypt/certbot-apache/Manifest
app-crypt/certbot-apache/certbot-apache-0.34.2.ebuild [deleted file]
app-crypt/certbot-nginx/Manifest
app-crypt/certbot-nginx/certbot-nginx-0.34.2.ebuild [deleted file]
app-crypt/certbot/Manifest
app-crypt/certbot/certbot-0.34.2.ebuild [deleted file]

index 8e39bf083ccc73158dc0d5c44e83b1492b8f8495..82a02c2e5569f9145f39c5a00f05c6a97a812052 100644 (file)
@@ -1,3 +1,2 @@
-DIST certbot-0.34.2.tar.gz 1347778 BLAKE2B 57195e3a7a3481c4c1fa184035b73b8b5e06a33f37b317d895381ec6c4b57852a475a3b76593b8fee9922f731512ed0d0423afa26b5c04138d24781df9da42f0 SHA512 63923b1d433f4c714318e848335e696e2412c574cc16f4fb1631caeebdce5a7f599985cf450e96dceb87a958c8f09a003e1d2f24eac1bdc183c7a5c43bb362de
 DIST certbot-0.35.0.tar.gz 1333065 BLAKE2B 8bd4fd735e68f24ee7c0533b18b63e2924eab9dcef78250f5d7094fbb04f78acca1c11cefae48e25da637a01a7dcd004f22926923b63a39206b63133193793a1 SHA512 ca94858aca5c6849dd6667d1e96389d80a7882de9a4deeda28d244ac105c1524dddb100dc899e4fabdef908607956617e26640b8e573b04a0625e19413c23bee
 DIST certbot-0.36.0.tar.gz 1322339 BLAKE2B 69fbf68b5dd95d6d3ac6c868d583da8c66dfcd01e3471c511d0d9d95de08ac096479733e9fca12ca99abf43484835fa7184dcccb1c11a41ee7948174364f2894 SHA512 f7fa8c6200a76b4fc4830865bf11fbba8bd73ea55e1236680181073952505c83b4650b43ccfc8e9b96caf47b85c43e47acf8db6d92134f7c279ebd954ab0ac92
diff --git a/app-crypt/acme/acme-0.34.2.ebuild b/app-crypt/acme/acme-0.34.2.ebuild
deleted file mode 100644 (file)
index f70241e..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=(python{2_7,3_5,3_6})
-
-if [[ ${PV} == 9999* ]]; then
-       EGIT_REPO_URI="https://github.com/certbot/certbot.git"
-       inherit git-r3
-       S=${WORKDIR}/${P}/${PN}
-else
-       SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
-       KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-       S=${WORKDIR}/certbot-${PV}/acme
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of the ACME protocol"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="doc test"
-
-RDEPEND="
-       >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
-       >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
-       >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
-       dev-python/mock[${PYTHON_USEDEP}]
-       >=dev-python/pyopenssl-0.13.1[${PYTHON_USEDEP}]
-       dev-python/pyrfc3339[${PYTHON_USEDEP}]
-       dev-python/pytz[${PYTHON_USEDEP}]
-       >=dev-python/requests-2.10[${PYTHON_USEDEP}]
-       >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
-       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-"
-DEPEND="
-       doc? (
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
-       )
-       test? (
-               ${RDEPEND}
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-xdist[${PYTHON_USEDEP}]
-       )
-       >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
-"
-
-src_compile() {
-       python_foreach_impl run_in_build_dir default
-       if use doc ; then
-               cd docs || die
-               sphinx-build -b html -d _build/doctrees   . _build/html
-       fi
-}
-
-python_test() {
-       nosetests -w ${PN} || die
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-
-       distutils-r1_python_install_all
-}
index 8e39bf083ccc73158dc0d5c44e83b1492b8f8495..82a02c2e5569f9145f39c5a00f05c6a97a812052 100644 (file)
@@ -1,3 +1,2 @@
-DIST certbot-0.34.2.tar.gz 1347778 BLAKE2B 57195e3a7a3481c4c1fa184035b73b8b5e06a33f37b317d895381ec6c4b57852a475a3b76593b8fee9922f731512ed0d0423afa26b5c04138d24781df9da42f0 SHA512 63923b1d433f4c714318e848335e696e2412c574cc16f4fb1631caeebdce5a7f599985cf450e96dceb87a958c8f09a003e1d2f24eac1bdc183c7a5c43bb362de
 DIST certbot-0.35.0.tar.gz 1333065 BLAKE2B 8bd4fd735e68f24ee7c0533b18b63e2924eab9dcef78250f5d7094fbb04f78acca1c11cefae48e25da637a01a7dcd004f22926923b63a39206b63133193793a1 SHA512 ca94858aca5c6849dd6667d1e96389d80a7882de9a4deeda28d244ac105c1524dddb100dc899e4fabdef908607956617e26640b8e573b04a0625e19413c23bee
 DIST certbot-0.36.0.tar.gz 1322339 BLAKE2B 69fbf68b5dd95d6d3ac6c868d583da8c66dfcd01e3471c511d0d9d95de08ac096479733e9fca12ca99abf43484835fa7184dcccb1c11a41ee7948174364f2894 SHA512 f7fa8c6200a76b4fc4830865bf11fbba8bd73ea55e1236680181073952505c83b4650b43ccfc8e9b96caf47b85c43e47acf8db6d92134f7c279ebd954ab0ac92
diff --git a/app-crypt/certbot-apache/certbot-apache-0.34.2.ebuild b/app-crypt/certbot-apache/certbot-apache-0.34.2.ebuild
deleted file mode 100644 (file)
index 4486089..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=(python{2_7,3_5,3_6})
-
-if [[ ${PV} == 9999* ]]; then
-       EGIT_REPO_URI="https://github.com/certbot/certbot.git"
-       inherit git-r3
-       S=${WORKDIR}/${P}/${PN}
-else
-       SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
-       KEYWORDS="amd64 ~arm64 x86"
-       S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-
-RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
-       >=app-crypt/certbot-0.34.0[${PYTHON_USEDEP}]
-       dev-python/mock[${PYTHON_USEDEP}]
-       dev-python/python-augeas[${PYTHON_USEDEP}]
-       dev-python/zope-component[${PYTHON_USEDEP}]
-       dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="test? ( ${RDEPEND}
-       dev-python/nose[${PYTHON_USEDEP}] )
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
-       nosetests || die
-}
index 8e39bf083ccc73158dc0d5c44e83b1492b8f8495..82a02c2e5569f9145f39c5a00f05c6a97a812052 100644 (file)
@@ -1,3 +1,2 @@
-DIST certbot-0.34.2.tar.gz 1347778 BLAKE2B 57195e3a7a3481c4c1fa184035b73b8b5e06a33f37b317d895381ec6c4b57852a475a3b76593b8fee9922f731512ed0d0423afa26b5c04138d24781df9da42f0 SHA512 63923b1d433f4c714318e848335e696e2412c574cc16f4fb1631caeebdce5a7f599985cf450e96dceb87a958c8f09a003e1d2f24eac1bdc183c7a5c43bb362de
 DIST certbot-0.35.0.tar.gz 1333065 BLAKE2B 8bd4fd735e68f24ee7c0533b18b63e2924eab9dcef78250f5d7094fbb04f78acca1c11cefae48e25da637a01a7dcd004f22926923b63a39206b63133193793a1 SHA512 ca94858aca5c6849dd6667d1e96389d80a7882de9a4deeda28d244ac105c1524dddb100dc899e4fabdef908607956617e26640b8e573b04a0625e19413c23bee
 DIST certbot-0.36.0.tar.gz 1322339 BLAKE2B 69fbf68b5dd95d6d3ac6c868d583da8c66dfcd01e3471c511d0d9d95de08ac096479733e9fca12ca99abf43484835fa7184dcccb1c11a41ee7948174364f2894 SHA512 f7fa8c6200a76b4fc4830865bf11fbba8bd73ea55e1236680181073952505c83b4650b43ccfc8e9b96caf47b85c43e47acf8db6d92134f7c279ebd954ab0ac92
diff --git a/app-crypt/certbot-nginx/certbot-nginx-0.34.2.ebuild b/app-crypt/certbot-nginx/certbot-nginx-0.34.2.ebuild
deleted file mode 100644 (file)
index d77b28c..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=(python{2_7,3_5,3_6})
-
-if [[ ${PV} == 9999* ]]; then
-       EGIT_REPO_URI="https://github.com/certbot/certbot.git"
-       inherit git-r3
-       S=${WORKDIR}/${P}/${PN}
-else
-       SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
-       KEYWORDS="amd64 ~arm ~arm64 x86"
-       S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
-       >=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
-       >=app-crypt/certbot-0.34.0[${PYTHON_USEDEP}]
-       dev-python/mock[${PYTHON_USEDEP}]
-       dev-python/pyopenssl[${PYTHON_USEDEP}]
-       >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
-       dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"
index 8e39bf083ccc73158dc0d5c44e83b1492b8f8495..82a02c2e5569f9145f39c5a00f05c6a97a812052 100644 (file)
@@ -1,3 +1,2 @@
-DIST certbot-0.34.2.tar.gz 1347778 BLAKE2B 57195e3a7a3481c4c1fa184035b73b8b5e06a33f37b317d895381ec6c4b57852a475a3b76593b8fee9922f731512ed0d0423afa26b5c04138d24781df9da42f0 SHA512 63923b1d433f4c714318e848335e696e2412c574cc16f4fb1631caeebdce5a7f599985cf450e96dceb87a958c8f09a003e1d2f24eac1bdc183c7a5c43bb362de
 DIST certbot-0.35.0.tar.gz 1333065 BLAKE2B 8bd4fd735e68f24ee7c0533b18b63e2924eab9dcef78250f5d7094fbb04f78acca1c11cefae48e25da637a01a7dcd004f22926923b63a39206b63133193793a1 SHA512 ca94858aca5c6849dd6667d1e96389d80a7882de9a4deeda28d244ac105c1524dddb100dc899e4fabdef908607956617e26640b8e573b04a0625e19413c23bee
 DIST certbot-0.36.0.tar.gz 1322339 BLAKE2B 69fbf68b5dd95d6d3ac6c868d583da8c66dfcd01e3471c511d0d9d95de08ac096479733e9fca12ca99abf43484835fa7184dcccb1c11a41ee7948174364f2894 SHA512 f7fa8c6200a76b4fc4830865bf11fbba8bd73ea55e1236680181073952505c83b4650b43ccfc8e9b96caf47b85c43e47acf8db6d92134f7c279ebd954ab0ac92
diff --git a/app-crypt/certbot/certbot-0.34.2.ebuild b/app-crypt/certbot/certbot-0.34.2.ebuild
deleted file mode 100644 (file)
index 813dc87..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=(python{2_7,3_5,3_6})
-
-if [[ ${PV} == 9999* ]]; then
-       EGIT_REPO_URI="https://github.com/certbot/certbot.git"
-       inherit git-r3
-else
-       SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="
-       ${CDEPEND}
-       >=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
-       >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
-       dev-python/configobj[${PYTHON_USEDEP}]
-       >=dev-python/cryptography-1.2[${PYTHON_USEDEP}]
-       >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
-       dev-python/mock[${PYTHON_USEDEP}]
-       >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
-       dev-python/pyrfc3339[${PYTHON_USEDEP}]
-       dev-python/pytz[${PYTHON_USEDEP}]
-       dev-python/zope-component[${PYTHON_USEDEP}]
-       dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="
-       ${CDEPEND}
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )"
-
-python_test() {
-       # acme is not installed, removing it here is fine, the dir just confuses tests
-       rm -R acme
-       pytest -vv ${PN} || die
-}