dev-ml/ocplib-endian: new ebuild
authorMatthew Brewer <tomboy64@sina.cn>
Fri, 16 Oct 2015 12:20:48 +0000 (14:20 +0200)
committerMatthew Brewer <tomboy64@sina.cn>
Fri, 16 Oct 2015 16:53:19 +0000 (18:53 +0200)
- needed as a transitive dependency of Libre S3 1.1 (net-misc/libres3)
- explicit support for MirageOS is not enabled

dev-ml/ocplib-endian/Manifest [new file with mode: 0644]
dev-ml/ocplib-endian/metadata.xml [new file with mode: 0644]
dev-ml/ocplib-endian/ocplib-endian-0.8.ebuild [new file with mode: 0644]

diff --git a/dev-ml/ocplib-endian/Manifest b/dev-ml/ocplib-endian/Manifest
new file mode 100644 (file)
index 0000000..57464cb
--- /dev/null
@@ -0,0 +1 @@
+DIST ocplib-endian-0.8.tar.gz 56733 SHA256 34a9ffda92459ae0ccd0b6e97cd947ed59f565f5a5776f51e18f5fec27c8ea44 SHA512 6978e9e306faf115d1b732e221dad8a1eea1c2eae12b5ca6f5462ee8b603900fcc585dc5a20e0a35fa793cf3d9fe50833b284a4385bc3d251e86457bf54a8697 WHIRLPOOL 9f595128d0c1281c56c70ef76522afa721d5b7e81199218b6509d9aa4b8a7c32b5f64b1d6b3dd65c9c7dc5a638233f3e46ef7ed1de88614f62d2a6a6c70e3be6
diff --git a/dev-ml/ocplib-endian/metadata.xml b/dev-ml/ocplib-endian/metadata.xml
new file mode 100644 (file)
index 0000000..a33970c
--- /dev/null
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+    <herd>ml</herd>
+    <herd>proxy-maintainers</herd>
+    <maintainer>
+        <email>tomboy64@sina.cn</email>
+    </maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocplib-endian/ocplib-endian-0.8.ebuild b/dev-ml/ocplib-endian/ocplib-endian-0.8.ebuild
new file mode 100644 (file)
index 0000000..445b2f8
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays"
+HOMEPAGE="https://github.com/OCamlPro/ocplib-endian"
+SRC_URI="https://github.com/OCamlPro/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+       >=dev-lang/ocaml-4.01
+       >=dev-ml/cppo-1.1.0
+"
+RDEPEND=""
+
+DOCS=( CHANGES.md COPYING.txt README.md )