app-xemacs/ebuild-mode: Version bump.
authorUlrich Müller <ulm@gentoo.org>
Tue, 17 Apr 2018 19:10:28 +0000 (21:10 +0200)
committerUlrich Müller <ulm@gentoo.org>
Tue, 17 Apr 2018 19:11:56 +0000 (21:11 +0200)
Package-Manager: Portage-2.3.29, Repoman-2.3.9

app-xemacs/ebuild-mode/Manifest
app-xemacs/ebuild-mode/ebuild-mode-1.43.ebuild [new file with mode: 0644]

index 72e9a5e115822f6ac1a14c27c22720ab4fcbe087..7e83220e4780c2e22761ebb57d638af1f872f2d7 100644 (file)
@@ -1 +1,2 @@
 DIST ebuild-mode-1.42.tar.xz 34936 BLAKE2B dd94d17dc57e2d32b329ab62ec6eec8ada6a4aeddadb8d978736f5dcb4d613759fd860043cab92d12db11614f8b7fa71fc5537576a2af3f5e6c9d56fc2fdcc05 SHA512 119f954eaf009bd0c9f0a75810b94a54d65ed91c6ffef20dd164c7a5ef095410dd0f3642426817f5efa6623d4f3e120ed3b27076222b02a90e75a83bb80b8703
+DIST ebuild-mode-1.43.tar.xz 34688 BLAKE2B 577900e2fa7ccb2362ec7f9046affb58e92bdfde44f2ea48274ba61d65f35fa6a1852bda6d9c64bd3f63aba99df244b4cb3378de079259508b149cdacf7caf28 SHA512 91f9a06de6feeeadb27d765a6ca6f2fa17e01938a6c953efe3586646f1bf48da87fe269ee9b07b2e16199d3ba4a76f42b8be9143218b808fac2971fc6f64f36d
diff --git a/app-xemacs/ebuild-mode/ebuild-mode-1.43.ebuild b/app-xemacs/ebuild-mode/ebuild-mode-1.43.ebuild
new file mode 100644 (file)
index 0000000..1288c72
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xemacs-elisp
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+RDEPEND=">=app-editors/xemacs-21.4.20-r5
+       app-xemacs/sh-script"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+       ${XEMACS_BATCH_CLEAN} -eval "(add-to-list 'load-path \".\")" \
+               -f batch-byte-compile ebuild-mode.el gentoo-newsitem-mode.el || die
+       xemacs-elisp-make-autoload-file \
+               ebuild-mode.el gentoo-newsitem-mode.el || die
+}