lxqt-base/lxqt-qtplugin: bump 'dev-libs/libqtxdg' dependency
authorJimi Huotari <chiitoo@gentoo.org>
Thu, 21 May 2020 17:49:47 +0000 (20:49 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 21 May 2020 19:47:43 +0000 (21:47 +0200)
Closes: https://bugs.gentoo.org/724436
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/15904
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.15.0-r1.ebuild [new file with mode: 0644]

diff --git a/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.15.0-r1.ebuild b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.15.0-r1.ebuild
new file mode 100644 (file)
index 0000000..00aeff1
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt system integration plugin for Qt"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+       SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+       dev-qt/linguist-tools:5
+       >=dev-util/lxqt-build-tools-0.7.0
+"
+DEPEND="
+       dev-libs/libdbusmenu-qt:=[qt5(+)]
+       >=dev-libs/libqtxdg-3.5.0
+       dev-qt/qtcore:5
+       dev-qt/qtdbus:5
+       dev-qt/qtgui:5=
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       =x11-libs/libfm-qt-$(ver_cut 1-2)*
+"
+RDEPEND="${DEPEND}"