distutils-r1.eclass: Pass --skip-build when installing
authorMichał Górny <mgorny@gentoo.org>
Sun, 22 Mar 2020 05:54:44 +0000 (06:54 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 14 Apr 2020 05:33:07 +0000 (07:33 +0200)
Explicitly pass --skip-build in order to prevent distutils from
rebuilding files when installing.  This is especially relevant to some
packages that build extensions, and the extensions get built again
in src_install().

Technically, this can break some customized build systems that write
implementation-specific data into source directory, and right now
the implied rebuild caused it to be rewritten when installing.  With
this patch, the newest version of the file would be installed for all
interpreters.  I am not aware of any such packages, though.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
eclass/distutils-r1.eclass

index fd6c0193d12e8d14bdaf3712f239f679f711b352..51e99a009df187f274ca11f21365a54b38a4445a 100644 (file)
@@ -873,7 +873,7 @@ distutils-r1_python_install() {
        local root=${D%/}/_${EPYTHON}
        [[ ${DISTUTILS_SINGLE_IMPL} ]] && root=${D%/}
 
-       esetup.py install --root="${root}" "${args[@]}"
+       esetup.py install --skip-build --root="${root}" "${args[@]}"
 
        local forbidden_package_names=( examples test tests .pytest_cache )
        local p