x11-libs/pango: bump to 1.40.5
authorMart Raudsepp <leio@gentoo.org>
Sun, 9 Apr 2017 00:18:39 +0000 (03:18 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 9 Apr 2017 00:26:23 +0000 (03:26 +0300)
Gentoo-bug: 612002

x11-libs/pango/Manifest
x11-libs/pango/pango-1.40.5.ebuild [new file with mode: 0644]

index f039f1a70e6c9506c88a2b31c9859d2dfbad7f17..bc69288395f539750556e492ccd101656743e311 100644 (file)
@@ -1,2 +1,3 @@
 DIST pango-1.40.3.tar.xz 1061044 SHA256 abba8b5ce728520c3a0f1535eab19eac3c14aeef7faa5aded90017ceac2711d3 SHA512 ff82395e8487624dffe212975b72b3383dcebb197a8675c8b409665e3e2e30fc23d9a6c25c3129a115adb7182b2a71a49550dbe881eb7ee9bbc572de6ba18d27 WHIRLPOOL ba160e7a9f5ecfbb4d88f780b4a9a5f555f38407d4f50f6ae0b0d276a3d4100dce4af519ceadce8b95c3432976af4409e119cfd18bd7c636d70e6c33ed7c5b4c
 DIST pango-1.40.4.tar.xz 1062600 SHA256 f8fdc5fc66356dc4edf915048cceeee065a0e0cb70b3b2598f62bda320129a3e SHA512 8c7413f6712eaf9fd4bd92a9260a85e7e4bd5e1a03c4c89db139e1704e8681e9834f8b98394b9f4b87babd45155a15b6cffd583ad8f89a48a4849305d43aa613 WHIRLPOOL c061c32c46171dfbf988f0c9498c19cef725d7f56e5dd57d042ebef2c408ba8299ff34eac03f590080d4657cd24f0d53737c224573c96584eb99b3f0fb1f4fdc
+DIST pango-1.40.5.tar.xz 1065152 SHA256 24748140456c42360b07b2c77a1a2e1216d07c056632079557cd4e815b9d01c9 SHA512 40e8bf85dbb4b6fd35da3acec06a0d2b9dde95a3c5a212d243dbcbc0d00f12bd061757a04cb2f4a8db61329efd7ed9be53e3f5d6a2eb2a3defba1d12f9eed43d WHIRLPOOL 8d8eec25ba18096ce9c5fae2ce9f1d54e908784482669daa8f505863f7b5529c50fd432fb93c3d8d6bb3ef2ac311c59e68667393dc0442335a97171c480d2294
diff --git a/x11-libs/pango/pango-1.40.5.ebuild b/x11-libs/pango/pango-1.40.5.ebuild
new file mode 100644 (file)
index 0000000..cc29059
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 multilib-minimal toolchain-funcs
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2+ FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="X +introspection test"
+
+RDEPEND="
+       >=media-libs/harfbuzz-0.9.30:=[glib(+),truetype(+),${MULTILIB_USEDEP}]
+       >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+       >=media-libs/fontconfig-2.10.92:1.0=[${MULTILIB_USEDEP}]
+       >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}]
+       >=x11-libs/cairo-1.12.14-r4:=[X?,${MULTILIB_USEDEP}]
+       introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+       X? (
+               >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+               >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+               >=x11-libs/libXft-2.3.1-r1[${MULTILIB_USEDEP}]
+       )
+"
+DEPEND="${RDEPEND}
+       >=dev-util/gtk-doc-am-1.20
+       virtual/pkgconfig[${MULTILIB_USEDEP}]
+       test? ( media-fonts/cantarell )
+       X? ( >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}] )
+       !<=sys-devel/autoconf-2.63:2.5
+"
+
+multilib_src_configure() {
+       tc-export CXX
+
+       ECONF_SOURCE=${S} \
+       gnome2_src_configure \
+               --with-cairo \
+               $(multilib_native_use_enable introspection) \
+               $(use_with X xft) \
+               "$(usex X --x-includes="${EPREFIX}/usr/include" "")" \
+               "$(usex X --x-libraries="${EPREFIX}/usr/$(get_libdir)" "")"
+
+       if multilib_is_native_abi; then
+               ln -s "${S}"/docs/html docs/html || die
+       fi
+}
+
+multilib_src_install() {
+       gnome2_src_install
+}