dev-dotnet/monocalendar: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 11:30:01 +0000 (12:30 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 11:38:51 +0000 (12:38 +0100)
Closes: https://bugs.gentoo.org/697366
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild

index a14d50d57957d0f9c148e01000e7e8e17ad70ad1..4837debd2b9f3412127f0f0a8290799c16c8975c 100644 (file)
@@ -1,17 +1,16 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
-inherit mono eutils multilib
-
-S="${WORKDIR}/MonoCalendar"
+inherit eutils mono
 
 DESCRIPTION="iCal clone for .NET"
 HOMEPAGE="http://www.monocalendar.com/"
 SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+S="${WORKDIR}/MonoCalendar"
 
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
 SLOT="0"
 KEYWORDS="~amd64 x86"
 IUSE=""
@@ -20,17 +19,13 @@ DEPEND=">=dev-lang/mono-1.2.1"
 RDEPEND="${DEPEND}"
 
 src_compile() {
-       cd "${S}"/bin/Release/
-
-       emake || die "emake failed"
+       emake -C bin/Release
 }
 
 src_install() {
-       dodir /usr/$(get_libdir)/${PN}
-       insinto /usr/$(get_libdir)/${PN}
-
-       doins bin/Release/*dll
-       doins bin/Release/*.exe
+       exeinto /usr/$(get_libdir)/${PN}
+       doexe bin/Release/*dll
+       doexe bin/Release/*.exe
 
        make_wrapper monocalendar "mono /usr/$(get_libdir)/${PN}/MonoCalendar.exe"
 }