app-crypt/openpgp-keys-gentoo-auth: Package the Authority Keys
authorMichał Górny <mgorny@gentoo.org>
Wed, 30 Oct 2019 15:45:38 +0000 (16:45 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 30 Oct 2019 16:34:43 +0000 (17:34 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-crypt/openpgp-keys-gentoo-auth/Manifest [new file with mode: 0644]
app-crypt/openpgp-keys-gentoo-auth/metadata.xml [new file with mode: 0644]
app-crypt/openpgp-keys-gentoo-auth/openpgp-keys-gentoo-auth-20191030.ebuild [new file with mode: 0644]

diff --git a/app-crypt/openpgp-keys-gentoo-auth/Manifest b/app-crypt/openpgp-keys-gentoo-auth/Manifest
new file mode 100644 (file)
index 0000000..0f11222
--- /dev/null
@@ -0,0 +1 @@
+DIST gentoo-auth.asc.20191030.gz 6556 BLAKE2B 233df81a8c01ead6524fdded0c64aba7d930d0f9e6214c403e43aa97bc87502a4e1d68c6c415505db5f618d9309d5ba1279d1e9b9e068289002ad30896a500c9 SHA512 c752dc4b5d75937290e469e722ccd48a592413438a7d1c5bc5d4e07114077ae3dfb5fc3cbe6b96d672e4149737cd7db6dc8298e670e63745bdff7426e98fc03b
diff --git a/app-crypt/openpgp-keys-gentoo-auth/metadata.xml b/app-crypt/openpgp-keys-gentoo-auth/metadata.xml
new file mode 100644 (file)
index 0000000..0319eec
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>mgorny@gentoo.org</email>
+               <name>Michał Górny</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/app-crypt/openpgp-keys-gentoo-auth/openpgp-keys-gentoo-auth-20191030.ebuild b/app-crypt/openpgp-keys-gentoo-auth/openpgp-keys-gentoo-auth-20191030.ebuild
new file mode 100644 (file)
index 0000000..a6f1305
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Gentoo Authority Keys (GLEP 79)"
+HOMEPAGE="https://www.gentoo.org/downloads/signatures/"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/openpgp-keys/gentoo-auth.asc.${PV}.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+
+S=${WORKDIR}
+
+src_install() {
+       insinto /usr/share/openpgp-keys
+       newins "gentoo-auth.asc.${PV}" gentoo-auth.asc
+       newins - gentoo-auth-ownertrust.txt <<-EOF
+               ABD00913019D6354BA1D9A132839FE0D796198B1:6:
+       EOF
+}