dev-dotnet/gkeyfile-sharp: Bump EAPI to 5, migrate to mono-env, support gtk-sharp...
authorChristoph Mende <angelos@gentoo.org>
Thu, 17 Sep 2015 17:17:46 +0000 (19:17 +0200)
committerChristoph Mende <angelos@gentoo.org>
Thu, 17 Sep 2015 19:01:04 +0000 (21:01 +0200)
Package-Manager: portage-2.2.20.1

dev-dotnet/gkeyfile-sharp/gkeyfile-sharp-0.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-dotnet/gkeyfile-sharp/gkeyfile-sharp-0.1-r1.ebuild b/dev-dotnet/gkeyfile-sharp/gkeyfile-sharp-0.1-r1.ebuild
new file mode 100644 (file)
index 0000000..b6cce4e
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools mono-env
+
+DESCRIPTION="C# binding for gkeyfile"
+HOMEPAGE="https://launchpad.net/gkeyfile-sharp https://github.com/mono/gkeyfile-sharp"
+SRC_URI="https://github.com/mono/${PN}/tarball/GKEYFILE_SHARP_0_1 -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( >=dev-dotnet/gtk-sharp-2.12.21 >=dev-dotnet/glib-sharp-2.12.9 )
+       || ( >=dev-dotnet/gtk-sharp-2.12.21 >=dev-dotnet/gtk-sharp-gapi-1.9 )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+src_unpack() {
+       unpack ${A}
+       mv *-${PN}-* "${S}"
+}
+
+src_prepare() {
+       mv configure.in configure.ac
+       sed -i -e 's/gmcs/mcs/' configure.ac || die
+       eautoreconf
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+       dodoc AUTHORS ChangeLog NEWS
+}