dev-java/oracle-jre-bin-1.8.0.202: bump
authorMiroslav Šulc <fordfrog@gentoo.org>
Thu, 17 Jan 2019 09:47:41 +0000 (10:47 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Thu, 17 Jan 2019 09:50:36 +0000 (10:50 +0100)
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
dev-java/oracle-jre-bin/Manifest
dev-java/oracle-jre-bin/oracle-jre-bin-1.8.0.202.ebuild [new file with mode: 0644]

index 5a30b69fc3297f95c85cdc716b457312965802b3..403b9df901f7c655c638324a9b72ccfdd428a7d8 100644 (file)
@@ -1,2 +1,4 @@
 DIST jre-8u192-linux-i586.tar.gz 87804679 BLAKE2B bb1dea51f0d45dcd3aabc82668790ee274c83f2e3c596d836d7b57c971ff6535881849cce5757132fed1b537a4a9677fbbb0b8b003d423d26ee72cb71047428f SHA512 5c749f358aa5b55513765eeb52dd2e0d3cb2b3223cc93739aa36445af8c6a3171a01cab673e106312e816c0a3b584a8a1be4aed1e2662e86b6d318d86a135485
 DIST jre-8u192-linux-x64.tar.gz 84597342 BLAKE2B 655db641df8349109e2944838f16f37ea208772580f0753e664a0642649745c123b2a781497ca3b9028f55c0bd2816cb5746d7d1d04cc83bb536ca0b467a4fc0 SHA512 d786f9e032bc286f3d4f361c382b6606c7462240b191d04606ca5ed9e59e3d7703cbaf1d57693c6763d00374c76c99cdb2f58c0bc372ef5c14c6304d556b4c8a
+DIST jre-8u202-linux-i586.tar.gz 90106000 BLAKE2B e756771caf8567c58870a267aafc9d48e98f06da1373a33bfdf40cc564c8df1645df38ad2f6951bc34d703bb0f4646b52ebf008dfc470231b4e93078c7730862 SHA512 573e32dc715d280084e71999e71a2875a488cbbba2b42c5107c55669c8842dd4ca6c6f42034b5e0b705c22a7a1d9799b456211034a6f351bc9d8e8fd803e0ad3
+DIST jre-8u202-linux-x64.tar.gz 86883826 BLAKE2B 8e69f4e8d6ce7d556ce7c8f30f5c71a50997103f729935269581f0af054fd1dc769b7099ad3a35d4baf41c8a6bdd76b049ae4908714701b196c4ce57ff61b39b SHA512 2460cde88162b00f5ca5600084f5f6b8720b8158869f5f5832fe886a5a6e839eb48398e9e3df47c45be257d9f6915e682d294d560b09e097ff610f09a76b1760
diff --git a/dev-java/oracle-jre-bin/oracle-jre-bin-1.8.0.202.ebuild b/dev-java/oracle-jre-bin/oracle-jre-bin-1.8.0.202.ebuild
new file mode 100644 (file)
index 0000000..0301c67
--- /dev/null
@@ -0,0 +1,220 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop gnome2-utils java-vm-2 prefix versionator
+
+KEYWORDS="-* ~amd64 ~x86"
+
+if [[ "$(get_version_component_range 4)" == 0 ]] ; then
+       S_PV="$(get_version_component_range 1-3)"
+else
+       MY_PV_EXT="u$(get_version_component_range 4)"
+       S_PV="$(get_version_component_range 1-4)"
+fi
+
+MY_PV="$(get_version_component_range 2)${MY_PV_EXT}"
+
+declare -A ARCH_FILES
+ARCH_FILES[amd64]="jre-${MY_PV}-linux-x64.tar.gz"
+ARCH_FILES[x86]="jre-${MY_PV}-linux-i586.tar.gz"
+
+for keyword in ${KEYWORDS//-\*} ; do
+       SRC_URI+=" ${keyword#\~}? ( ${ARCH_FILES[${keyword#\~}]} )"
+done
+
+DESCRIPTION="Oracle's Java SE Runtime Environment"
+HOMEPAGE="http://www.oracle.com/technetwork/java/javase/"
+LICENSE="Oracle-BCLA-JavaSE"
+SLOT="1.8"
+IUSE="alsa commercial cups +fontconfig headless-awt javafx jce nsplugin selinux"
+RESTRICT="fetch preserve-libs strip"
+QA_PREBUILT="*"
+
+# NOTES:
+#
+# * cups is dlopened.
+#
+# * libpng is also dlopened but only by libsplashscreen, which isn't
+#   important, so we can exclude that.
+#
+# * We still need to work out the exact AWT and JavaFX dependencies
+#   under MacOS. It doesn't appear to use many, if any, of the
+#   dependencies below.
+#
+RDEPEND="!x64-macos? (
+               !headless-awt? (
+                       x11-libs/libX11
+                       x11-libs/libXext
+                       x11-libs/libXi
+                       x11-libs/libXrender
+                       x11-libs/libXtst
+               )
+               javafx? (
+                       dev-libs/glib:2
+                       dev-libs/libxml2:2
+                       dev-libs/libxslt
+                       media-libs/freetype:2
+                       x11-libs/cairo
+                       x11-libs/gtk+:2
+                       x11-libs/libX11
+                       x11-libs/libXtst
+                       x11-libs/libXxf86vm
+                       x11-libs/pango
+                       virtual/opengl
+               )
+       )
+       alsa? ( media-libs/alsa-lib )
+       cups? ( net-print/cups )
+       fontconfig? ( media-libs/fontconfig:1.0 )
+       !prefix? ( sys-libs/glibc:* )
+       selinux? ( sec-policy/selinux-java )"
+
+DEPEND="app-arch/zip"
+
+S="${WORKDIR}/jre$(replace_version_separator 3 _  ${S_PV})"
+
+pkg_nofetch() {
+       einfo "Please download ${ARCH_FILES[${ARCH}]} and move it to"
+       einfo "your distfiles directory:"
+       einfo
+       einfo "  http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html"
+       einfo
+       einfo "If the above mentioned URL does not point to the correct version anymore,"
+       einfo "please download the file from Oracle's Java download archive:"
+       einfo
+       einfo "  http://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html"
+       einfo
+}
+
+src_prepare() {
+       default
+
+       # Remove the hook that calls Oracle's evil usage tracker. Not just
+       # because it's evil but because it breaks the sandbox during builds
+       # and we can't find any other feasible way to disable it or make it
+       # write somewhere else. See bug #559936 for details.
+       zip -d lib/rt.jar sun/misc/PostVMInitHook.class || die
+}
+
+src_install() {
+       local dest="/opt/${P}"
+       local ddest="${ED}${dest#/}"
+
+       # Create files used as storage for system preferences.
+       mkdir .systemPrefs || die
+       touch .systemPrefs/.system.lock || die
+       touch .systemPrefs/.systemRootModFile || die
+
+       if ! use alsa ; then
+               rm -vf lib/*/libjsoundalsa.* || die
+       fi
+
+       if ! use commercial ; then
+               rm -vfr lib/jfr* || die
+       fi
+
+       if use headless-awt ; then
+               rm -vf lib/*/lib*{[jx]awt,splashscreen}* \
+                  bin/{javaws,policytool} || die
+       fi
+
+       if ! use javafx ; then
+               rm -vf lib/*/lib*{decora,fx,glass,prism}* \
+                  lib/*/libgstreamer-lite.* lib/{,ext/}*fx* || die
+       fi
+
+       if ! use nsplugin ; then
+               rm -vf lib/*/libnpjp2.* || die
+       else
+               local nsplugin=$(echo lib/*/libnpjp2.*)
+               local nsplugin_link=${nsplugin##*/}
+               nsplugin_link=${nsplugin_link/./-${PN}-${SLOT}.}
+               dosym "${dest}/${nsplugin}" "/usr/$(get_libdir)/nsbrowser/plugins/${nsplugin_link}"
+       fi
+
+       # Even though plugins linked against multiple ffmpeg versions are
+       # provided, they generally lag behind what Gentoo has available.
+       rm -vf lib/*/libavplugin* || die
+
+       # Prune all fontconfig files so that libfontconfig will be used.
+       rm -v lib/fontconfig.* || die
+
+       # Install desktop file for the Java Control Panel. Using
+       # ${PN}-${SLOT} to prevent file collision with JDK and other slots.
+       if [[ -d lib/desktop/icons ]] ; then
+               local icon
+               pushd lib/desktop/icons >/dev/null || die
+               for icon in */*/apps/sun-jcontrol.png ; do
+                       insinto /usr/share/icons/"${icon%/*}"
+                       newins "${icon}" sun-jcontrol-${PN}-${SLOT}.png
+               done
+               popd >/dev/null || die
+               make_desktop_entry \
+                       "${dest}"/bin/jcontrol \
+                       "Java Control Panel for Oracle JRE ${SLOT}" \
+                       sun-jcontrol-${PN}-${SLOT} \
+                       "Settings;Java;"
+       fi
+
+       dodoc COPYRIGHT
+       dodir "${dest}"
+       cp -pPR bin lib man "${ddest}" || die
+
+       ln -s policy/$(usex jce unlimited limited)/{US_export,local}_policy.jar \
+               "${ddest}"/lib/security/ || die
+
+       # Only install Gentoo-specific fontconfig if flag is disabled.
+       # https://docs.oracle.com/javase/8/docs/technotes/guides/intl/fontconfig.html
+       if ! use fontconfig ; then
+               insinto "${dest}"/lib/
+               doins "$(prefixify_ro "${FILESDIR}"/fontconfig.properties)"
+       fi
+
+       # Needs to be done before CDS, bug #215225.
+       java-vm_set-pax-markings "${ddest}"
+
+       # See bug #207282.
+       einfo "Creating the Class Data Sharing archives"
+       case ${ARCH} in
+               arm|ia64)
+                       ${ddest}/bin/java -client -Xshare:dump || die
+                       ;;
+               x86)
+                       ${ddest}/bin/java -client -Xshare:dump || die
+                       # limit heap size for large memory on x86 #467518
+                       # this is a workaround and shouldn't be needed.
+                       ${ddest}/bin/java -server -Xms64m -Xmx64m -Xshare:dump || die
+                       ;;
+               *)
+                       ${ddest}/bin/java -server -Xshare:dump || die
+                       ;;
+       esac
+
+       # Remove empty dirs we might have copied.
+       find "${D}" -type d -empty -exec rmdir -v {} + || die
+
+       java-vm_install-env "${FILESDIR}"/${PN}.env.sh
+       java-vm_revdep-mask
+       java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
+}
+
+pkg_preinst() {
+       gnome2_icon_savelist
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+       java-vm-2_pkg_postinst
+
+       if ! use headless-awt && ! use javafx ; then
+               ewarn "You have disabled the javafx flag. Some modern desktop Java applications"
+               ewarn "require this and they may fail with a confusing error message."
+       fi
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+       java-vm-2_pkg_postrm
+}