dev-python/translate-toolkit: Drop PYTHON_USEDEP from dev-python/sphinx
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 24 Nov 2019 20:27:27 +0000 (21:27 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 24 Nov 2019 20:48:17 +0000 (21:48 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/translate-toolkit/translate-toolkit-2.4.0.ebuild

index b45fd6a1b2e7ca1fca8ccafc9a5ce0dccb2d097d..f53688890d7484e0218105a2435b6d774ecfaeca 100644 (file)
@@ -18,12 +18,11 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
 IUSE="doc +html +ical +ini +subtitles +yaml"
 
 REQUIRED_USE="${PYTHON_REQUIRED_USE}
-       doc? ( || ( $(python_gen_useflags python3_6 python3_7) ) )
        subtitles? ( || ( $(python_gen_useflags python3_6 python3_7) ) )"
 
 BDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( $(python_gen_cond_dep 'dev-python/sphinx[${PYTHON_USEDEP}]' python3_6 python3_7) )
+       doc? ( dev-python/sphinx )
 "
 DEPEND="
        >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
@@ -75,6 +74,4 @@ python_install_all() {
        if ! use subtitles; then
                rm "${ED}"/usr/bin/{sub2po,po2sub} || die
        fi
-
-       python_optimize
 }