dev-ruby/minitest: add ruby22
authorHans de Graaff <graaff@gentoo.org>
Mon, 14 Aug 2017 18:57:08 +0000 (20:57 +0200)
committerHans de Graaff <graaff@gentoo.org>
Mon, 14 Aug 2017 19:42:02 +0000 (21:42 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-ruby/minitest/minitest-4.7.5-r1.ebuild

index 94564adcebb09a793ea06935f7eb9dd88b6805a3..e93ccde1f786b709da510e8d8446c287df8375d4 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
-USE_RUBY="ruby20 ruby21"
+USE_RUBY="ruby21 ruby22"
 
 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
 
@@ -20,5 +20,5 @@ KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~
 IUSE="doc test"
 
 each_ruby_test() {
-       ${RUBY} -Ilib:bin:test:. -S testrb test || die
+       ${RUBY} -Ilib:bin:test:. -S testrb-2 test || die
 }