sys-devel/llvm: move dev-lang/perl to BDEPEND wrt #694460
authorstefson <herrtimson@yahoo.de>
Mon, 16 Sep 2019 07:00:02 +0000 (09:00 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Sep 2019 15:05:27 +0000 (17:05 +0200)
dev-lang/perl is a build time dependency of llvm, only during cross
compile it must be run by the host (CBUILD) and not the target (CHOST).
Moving it to BDEPEND solves the issue of dev-lang/perl and friends
getting pulled into the dependency graph as compile time dependencies
during cross compile. BDEPEND has been introduced in EAPI=7, so the fix
is only possible for >=llvm-9.x

Closes: https://bugs.gentoo.org/694460
Signed-off-by: Steffen Kuhn <nielson2@yandex.com>
Closes: https://github.com/gentoo/gentoo/pull/12941
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/llvm/llvm-10.0.0.9999.ebuild
sys-devel/llvm/llvm-9.0.0.9999.ebuild

index 0fbb96cebb24c74977b5b4ffce3751ca8f55ce23..bacec8033f4ea47cd57b9156b0ae254ce243821d 100644 (file)
@@ -55,7 +55,6 @@ RDEPEND="
        z3? ( >=sci-mathematics/z3-4.7.1:0=[${MULTILIB_USEDEP}] )"
 # configparser-3.2 breaks the build (3.3 or none at all are fine)
 DEPEND="${RDEPEND}
-       dev-lang/perl
        || ( >=sys-devel/gcc-3.0 >=sys-devel/llvm-3.5
                ( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
        )
@@ -75,6 +74,7 @@ DEPEND="${RDEPEND}
 # installed means llvm-config there will take precedence.
 RDEPEND="${RDEPEND}
        !sys-devel/llvm:0"
+BDEPEND="dev-lang/perl"
 PDEPEND="sys-devel/llvm-common
        gold? ( >=sys-devel/llvmgold-${SLOT} )"
 
index abd71ac5d2c3df0b5abe1b170ebab35696609008..f294d0937069f1197e9aad9609241113eb91c03b 100644 (file)
@@ -53,7 +53,6 @@ RDEPEND="
        z3? ( >=sci-mathematics/z3-4.7.1:0=[${MULTILIB_USEDEP}] )"
 # configparser-3.2 breaks the build (3.3 or none at all are fine)
 DEPEND="${RDEPEND}
-       dev-lang/perl
        || ( >=sys-devel/gcc-3.0 >=sys-devel/llvm-3.5
                ( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
        )
@@ -73,6 +72,7 @@ DEPEND="${RDEPEND}
 # installed means llvm-config there will take precedence.
 RDEPEND="${RDEPEND}
        !sys-devel/llvm:0"
+BDEPEND="dev-lang/perl"
 PDEPEND="sys-devel/llvm-common
        gold? ( >=sys-devel/llvmgold-${SLOT} )"