x11-libs/gdk-pixbuf: fix TIFF loading support, bug #629716
authorGilles Dartiguelongue <eva@gentoo.org>
Fri, 15 Sep 2017 06:40:41 +0000 (08:40 +0200)
committerGilles Dartiguelongue <eva@gentoo.org>
Fri, 15 Sep 2017 06:42:48 +0000 (08:42 +0200)
Closes: https://bugs.gentoo.org/show_bug.cgi?id=629716
Package-Manager: Portage-2.3.8, Repoman-2.3.3

x11-libs/gdk-pixbuf/files/2.36.10-fix-tiff-loader.patch [new file with mode: 0644]
x11-libs/gdk-pixbuf/gdk-pixbuf-2.36.10-r1.ebuild [new file with mode: 0644]

diff --git a/x11-libs/gdk-pixbuf/files/2.36.10-fix-tiff-loader.patch b/x11-libs/gdk-pixbuf/files/2.36.10-fix-tiff-loader.patch
new file mode 100644 (file)
index 0000000..47e62ef
--- /dev/null
@@ -0,0 +1,66 @@
+From 66537d1ecf7e857a0a443c1ebf72baf6f19dd3e4 Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Mon, 11 Sep 2017 19:11:50 +0200
+Subject: build: Fix TIFF loader compilation with autotools
+
+https://bugzilla.gnome.org/show_bug.cgi?id=786342
+---
+ configure.ac           | 7 +++----
+ gdk-pixbuf/Makefile.am | 2 +-
+ 2 files changed, 4 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 0abe5ce..c07bd6f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -564,7 +564,6 @@ dnl Test for libjasper
+ *** --without-libjasper to configure])
+   fi
+-AC_SUBST(LIBTIFF)
+ AC_SUBST(LIBJPEG)
+ AC_SUBST(LIBPNG)
+ AC_SUBST(LIBJASPER)
+@@ -676,7 +675,7 @@ if test x$gio_can_sniff = x; then
+   AC_DEFINE(GDK_PIXBUF_USE_GIO_MIME, 1, [Define if gio can sniff image data])
+ fi
+-AM_CONDITIONAL(HAVE_TIFF, test "x$LIBTIFF" != x)
++AM_CONDITIONAL(HAVE_TIFF, test "x$libtiff_found" != x)
+ AM_CONDITIONAL(HAVE_PNG, test "x$LIBPNG" != x)
+ AM_CONDITIONAL(HAVE_JPEG, test "x$LIBJPEG" != x)
+ AM_CONDITIONAL(HAVE_JASPER, test "x$LIBJASPER" != x)
+@@ -684,7 +683,7 @@ AM_CONDITIONAL(HAVE_JASPER, test "x$LIBJASPER" != x)
+ if $dynworks ; then
+   STATIC_LIB_DEPS=
+   if echo "$included_loaders" | egrep '(^|,)tiff($|,)' > /dev/null; then
+-    STATIC_LIB_DEPS="$STATIC_LIB_DEPS $LIBTIFF"
++    STATIC_LIB_DEPS="$STATIC_LIB_DEPS $TIFF_LIBS"
+   fi
+   if echo "$included_loaders" | egrep '(^|,)jpeg($|,)' > /dev/null; then
+     STATIC_LIB_DEPS="$STATIC_LIB_DEPS $LIBJPEG"
+@@ -698,7 +697,7 @@ if $dynworks ; then
+     STATIC_LIB_DEPS="$STATIC_LIB_DEPS $LIBJASPER"
+   fi
+ else
+-  STATIC_LIB_DEPS="$LIBTIFF $LIBJPEG $LIBPNG $LIBJASPER"
++  STATIC_LIB_DEPS="$TIFF_LIBS $LIBJPEG $LIBPNG $LIBJASPER"
+ fi
+ # Checks to see whether we should include mediaLib
+diff --git a/gdk-pixbuf/Makefile.am b/gdk-pixbuf/Makefile.am
+index 01b693c..720a058 100644
+--- a/gdk-pixbuf/Makefile.am
++++ b/gdk-pixbuf/Makefile.am
+@@ -88,7 +88,7 @@ libpixbufloader_pnm_la_LIBADD = $(module_libs)
+ libstatic_pixbufloader_tiff_la_SOURCES = io-tiff.c
+ libpixbufloader_tiff_la_SOURCES = io-tiff.c
+ libpixbufloader_tiff_la_LDFLAGS = -avoid-version -module $(no_undefined)
+-libpixbufloader_tiff_la_LIBADD = $(LIBTIFF) $(module_libs)
++libpixbufloader_tiff_la_LIBADD = $(TIFF_LIBS) $(module_libs)
+ #
+ # The XPM loader
+-- 
+cgit v0.12
+
diff --git a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.36.10-r1.ebuild b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.36.10-r1.ebuild
new file mode 100644 (file)
index 0000000..b56eb7c
--- /dev/null
@@ -0,0 +1,124 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+GNOME2_EAUTORECONF="yes"
+
+inherit flag-o-matic gnome2 multilib multilib-minimal
+
+DESCRIPTION="Image loading library for GTK+"
+HOMEPAGE="https://git.gnome.org/browse/gdk-pixbuf"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="X debug +introspection jpeg jpeg2k tiff test"
+
+COMMON_DEPEND="
+       >=dev-libs/glib-2.48.0:2[${MULTILIB_USEDEP}]
+       >=media-libs/libpng-1.4:0=[${MULTILIB_USEDEP}]
+       introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
+       jpeg? ( virtual/jpeg:0=[${MULTILIB_USEDEP}] )
+       jpeg2k? ( media-libs/jasper:=[${MULTILIB_USEDEP}] )
+       tiff? ( >=media-libs/tiff-3.9.2:0=[${MULTILIB_USEDEP}] )
+       X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
+"
+DEPEND="${COMMON_DEPEND}
+       >=dev-util/gtk-doc-am-1.20
+       >=sys-devel/gettext-0.19
+       virtual/pkgconfig
+"
+# librsvg blocker is for the new pixbuf loader API, you lose icons otherwise
+RDEPEND="${COMMON_DEPEND}
+       !<gnome-base/gail-1000
+       !<gnome-base/librsvg-2.31.0
+       !<x11-libs/gtk+-2.21.3:2
+       !<x11-libs/gtk+-2.90.4:3
+"
+
+MULTILIB_CHOST_TOOLS=(
+       /usr/bin/gdk-pixbuf-query-loaders$(get_exeext)
+)
+
+PATCHES=(
+       # See https://bugzilla.gnome.org/show_bug.cgi?id=756590
+       "${FILESDIR}"/${PN}-2.32.3-fix-lowmem-uclibc.patch
+       # Fix TIFF loader compilation, bug #629716 (from master)
+       "${FILESDIR}"/2.36.10-fix-tiff-loader.patch
+)
+
+src_prepare() {
+       # This will avoid polluting the pkg-config file with versioned libpng,
+       # which is causing problems with libpng14 -> libpng15 upgrade
+       # See upstream bug #667068
+       # First check that the pattern is present, to catch upstream changes on bumps,
+       # because sed doesn't return failure code if it doesn't do any replacements
+       grep -q  'l in libpng16' configure || die "libpng check order has changed upstream"
+       sed -e 's:l in libpng16:l in libpng libpng16:' -i configure || die
+       [[ ${CHOST} == *-solaris* ]] && append-libs intl
+
+       gnome2_src_prepare
+}
+
+multilib_src_configure() {
+       # png always on to display icons
+       ECONF_SOURCE="${S}" \
+       gnome2_src_configure \
+               $(usex debug --enable-debug=yes "") \
+               $(use_with jpeg libjpeg) \
+               $(use_with jpeg2k libjasper) \
+               $(use_with tiff libtiff) \
+               $(multilib_native_use_enable introspection) \
+               $(use_with X x11) \
+               --with-libpng
+
+       # work-around gtk-doc out-of-source brokedness
+       if multilib_is_native_abi; then
+               ln -s "${S}"/docs/reference/${PN}/html docs/reference/${PN}/html || die
+       fi
+}
+
+multilib_src_install() {
+       # Parallel install fails when no gdk-pixbuf is already installed, bug #481372
+       MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_install
+}
+
+pkg_preinst() {
+       gnome2_pkg_preinst
+
+       multilib_pkg_preinst() {
+               # Make sure loaders.cache belongs to gdk-pixbuf alone
+               local cache="usr/$(get_libdir)/${PN}-2.0/2.10.0/loaders.cache"
+
+               if [[ -e ${EROOT}${cache} ]]; then
+                       cp "${EROOT}"${cache} "${ED}"/${cache} || die
+               else
+                       touch "${ED}"/${cache} || die
+               fi
+       }
+
+       multilib_foreach_abi multilib_pkg_preinst
+}
+
+pkg_postinst() {
+       # causes segfault if set, see bug 375615
+       unset __GL_NO_DSO_FINALIZER
+
+       multilib_foreach_abi gnome2_pkg_postinst
+
+       # Migration snippet for when this was handled by gtk+
+       if [ -e "${EROOT}"usr/lib/gtk-2.0/2.*/loaders ]; then
+               elog "You need to rebuild ebuilds that installed into" "${EROOT}"usr/lib/gtk-2.0/2.*/loaders
+               elog "to do that you can use qfile from portage-utils:"
+               elog "emerge -va1 \$(qfile -qC ${EPREFIX}/usr/lib/gtk-2.0/2.*/loaders)"
+       fi
+}
+
+pkg_postrm() {
+       gnome2_pkg_postrm
+
+       if [[ -z ${REPLACED_BY_VERSION} ]]; then
+               rm -f "${EROOT}"usr/lib*/${PN}-2.0/2.10.0/loaders.cache
+       fi
+}