app-metrics/fusioninventory-agent: Fix agent daemon startup
authorAlexey Shvetsov <alexxy@gentoo.org>
Wed, 27 May 2020 11:20:09 +0000 (14:20 +0300)
committerAlexey Shvetsov <alexxy@gentoo.org>
Wed, 27 May 2020 11:20:20 +0000 (14:20 +0300)
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
app-metrics/fusioninventory-agent/files/fusioninventory-agent-2.5.2-dirs.patch
app-metrics/fusioninventory-agent/fusioninventory-agent-2.5.2.ebuild

index e37b58c43a0cb3b5e1266604936d0837a5a982ec..a3a6b439713cdfbb6304bd589e0e063641169783 100644 (file)
@@ -1,5 +1,33 @@
---- a/Makefile.PL      2020-05-27 02:16:42.106531746 +0300
-+++ b/Makefile.PL      2020-05-27 02:17:30.568531767 +0300
+diff -urN a/lib/FusionInventory/Agent/Config.pm b/lib/FusionInventory/Agent/Config.pm
+--- a/lib/FusionInventory/Agent/Config.pm      2020-05-27 11:09:31.969999393 -0000
++++ b/lib/FusionInventory/Agent/Config.pm      2020-05-27 11:09:39.833332729 -0000
+@@ -67,7 +67,7 @@
+     my ($class, %params) = @_;
+     my $self = {
+-        '_confdir' => undef, # SYSCONFDIR replaced here from Makefile
++        '_confdir' => '/etc/fusioninventory', # SYSCONFDIR replaced here from Makefile
+     };
+     bless $self, $class;
+     $self->_loadDefaults();
+diff -urN a/lib/setup.pm b/lib/setup.pm
+--- a/lib/setup.pm     2020-05-27 11:09:31.989999393 -0000
++++ b/lib/setup.pm     2020-05-27 11:11:02.233332727 -0000
+@@ -11,9 +11,9 @@
+ our @EXPORT = ('%setup');
+ our %setup = (
+-    datadir => './share',
++    datadir => '/usr/share/fusioninventory',
+     libdir  => './lib',
+-    vardir  => './var',
++    vardir  => '/var/lib/fusioninventory',
+ );
+ # Compute directly libdir from this setup file as it should be installed
+diff -urN a/Makefile.PL b/Makefile.PL
+--- a/Makefile.PL      2020-05-27 11:09:31.966666059 -0000
++++ b/Makefile.PL      2020-05-27 11:09:39.833332729 -0000
 @@ -170,18 +170,15 @@
          INSTALLSCRIPT        => '$(PREFIX)/bin',
          INSTALLSITESCRIPT    => '$(PREFIX)/bin',
      );
  
      # allow variables defined on command line to override defaults
---- a/lib/FusionInventory/Agent/Config.pm     2020-05-27 10:06:21.248964808 +0300
-+++ b/lib/FusionInventory/Agent/Config.pm     2020-05-27 10:06:57.324964823 +0300
-@@ -67,7 +67,7 @@
-     my ($class, %params) = @_;
-     my $self = {
--        '_confdir' => undef, # SYSCONFDIR replaced here from Makefile
-+        '_confdir' => '/etc/fusioninventory', # SYSCONFDIR replaced here from Makefile
-     };
-     bless $self, $class;
-     $self->_loadDefaults();
-
index 9b0a5d9d145c8526c8246aa5809cf002ca3fb435..50d906752ad4b915f951a120d94de8e0c594af73 100644 (file)
@@ -21,6 +21,7 @@ DEPEND="
        dev-perl/Text-Template
        dev-perl/UNIVERSAL-require
        dev-perl/XML-TreePP
+       dev-perl/XML-XPath
        virtual/perl-IO-Compress
        dev-perl/HTTP-Daemon
        dev-perl/IO-Socket-SSL