sys-devel/parity: EAPI 7, revbump, old
authorMichael Haubenwallner <haubi@gentoo.org>
Thu, 12 Mar 2020 06:53:27 +0000 (07:53 +0100)
committerMichael Haubenwallner <haubi@gentoo.org>
Thu, 12 Mar 2020 06:54:41 +0000 (07:54 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Michael Haubenwallner <haubi@gentoo.org>
sys-devel/parity/Manifest
sys-devel/parity/parity-2.0.1.ebuild [moved from sys-devel/parity/parity-2.0.0.ebuild with 96% similarity]
sys-devel/parity/parity-9999.ebuild

index c740aca6a7bd2acc8a70e7fd7367c32d98387df9..c3d3a17e4c48ca5363c2c9d335a0e843a86ef072 100644 (file)
@@ -1 +1 @@
-DIST parity-2.0.0.tar.bz2 371278 BLAKE2B 49a183c7249d83757b9596dad71ad4feb4fbcc63966cfc90da50cce5fb03aa4118360165640ad3ebe73e0a37da7efdd3583685fa084ba7bffa8f6c2c2168ef7c SHA512 ff0b166d400bc7e14ec3c46c2f7fa32a4dfd69f044d20ea97d7fc6361493f5def682dfc7b51e09619357d1e88c5b44e1105b785be3ed1f58c38eb3d35a9bc748
+DIST parity-2.0.1.tar.bz2 371662 BLAKE2B c0fca272665bbe346d5d5ca18e06c65209df61454310811b939239f8ba25ec7a08ad2f864fb43780329dc1f0120afdb6ea4ee2b4b42d2888860358aa1dc176f4 SHA512 3c96c87b87f40cb7affd6ee9a87c8e7cf628aedb44a2d3d89370a5b5e32a43cb15a897ae27425e9d6a00581ffd50a70c7a7481f1ca259eddd1e6f2310b554eb9
similarity index 96%
rename from sys-devel/parity/parity-2.0.0.ebuild
rename to sys-devel/parity/parity-2.0.1.ebuild
index 24c5d7682b3becd4256bfcce1f07198575f15241..7f41d7bf06e61d1bfeff631f96cb805126f7e608 100644 (file)
@@ -1,12 +1,12 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 if [[ ${PV} == 9999 ]]; then
        inherit autotools git-r3
        EGIT_REPO_URI="git@github.com:haubi/parity.git https://github.com/haubi/parity.git"
-       DEPEND="dev-util/confix"
+       BDEPEND="dev-util/confix"
 else
        SRC_URI="https://github.com/mduft/${PN}/releases/download/${PV}/${P}.tar.bz2"
        KEYWORDS="~x64-cygwin"
@@ -68,7 +68,7 @@ src_configure() {
 }
 
 pkg_postinst() {
-       if [[ -n ${ROOT%/} ]] ; then
+       if [[ -n ${ROOT} ]] ; then
                einfo "To enable all available MSVC versions, on the target machine please run:"
                einfo " '${EPREFIX}/usr/bin/parity-setup' --enable-all"
        else
index 24c5d7682b3becd4256bfcce1f07198575f15241..7f41d7bf06e61d1bfeff631f96cb805126f7e608 100644 (file)
@@ -1,12 +1,12 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 if [[ ${PV} == 9999 ]]; then
        inherit autotools git-r3
        EGIT_REPO_URI="git@github.com:haubi/parity.git https://github.com/haubi/parity.git"
-       DEPEND="dev-util/confix"
+       BDEPEND="dev-util/confix"
 else
        SRC_URI="https://github.com/mduft/${PN}/releases/download/${PV}/${P}.tar.bz2"
        KEYWORDS="~x64-cygwin"
@@ -68,7 +68,7 @@ src_configure() {
 }
 
 pkg_postinst() {
-       if [[ -n ${ROOT%/} ]] ; then
+       if [[ -n ${ROOT} ]] ; then
                einfo "To enable all available MSVC versions, on the target machine please run:"
                einfo " '${EPREFIX}/usr/bin/parity-setup' --enable-all"
        else