New upstream release.
authorChris PeBenito <pebenito@gentoo.org>
Thu, 15 Feb 2007 05:26:21 +0000 (05:26 +0000)
committerChris PeBenito <pebenito@gentoo.org>
Thu, 15 Feb 2007 05:26:21 +0000 (05:26 +0000)
Package-Manager: portage-2.1.2-r9

sys-libs/libselinux/ChangeLog
sys-libs/libselinux/files/digest-libselinux-1.28-r1
sys-libs/libselinux/files/digest-libselinux-1.34.0 [new file with mode: 0644]
sys-libs/libselinux/libselinux-1.34.0.ebuild [new file with mode: 0644]
sys-libs/libsemanage/ChangeLog
sys-libs/libsemanage/files/digest-libsemanage-1.10.0 [new file with mode: 0644]
sys-libs/libsemanage/libsemanage-1.10.0.ebuild [new file with mode: 0644]
sys-libs/libsepol/ChangeLog
sys-libs/libsepol/files/digest-libsepol-1.10
sys-libs/libsepol/files/digest-libsepol-1.16.0 [new file with mode: 0644]
sys-libs/libsepol/libsepol-1.16.0.ebuild [new file with mode: 0644]

index 932fc2219e3e7d2c66d0e8129e87497582525d85..de7ef17b2a723644649afdbdda5b0c9c560471a9 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sys-libs/libselinux
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.51 2006/10/23 23:54:12 pebenito Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.52 2007/02/15 05:23:51 pebenito Exp $
+
+*libselinux-1.34.0 (15 Feb 2007)
+
+  15 Feb 2007; Chris PeBenito <pebenito@gentoo.org>
+  +libselinux-1.34.0.ebuild:
+  New upstream release.
 
   23 Oct 2006; Chris PeBenito <pebenito@gentoo.org>
   libselinux-1.30.29.ebuild:
index c05515454d1736e13489c9a435475c11588d5ac4..088baa4d47210ebf8f187b71a40b469ab38a6ddf 100644 (file)
@@ -1 +1,3 @@
 MD5 7e121e125b52913237df458ff610e983 libselinux-1.28.tgz 109236
+RMD160 9060d13850ddf43025988f1855fcc176db932881 libselinux-1.28.tgz 109236
+SHA256 9c03f98eb2800c383818275fb5abd2e9dc4c79c1b4c6ea35f11eedac902d03f6 libselinux-1.28.tgz 109236
diff --git a/sys-libs/libselinux/files/digest-libselinux-1.34.0 b/sys-libs/libselinux/files/digest-libselinux-1.34.0
new file mode 100644 (file)
index 0000000..5afefe2
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 ca56ee48af295f28eb3d59a6e71f92f5 libselinux-1.34.0.tgz 125574
+RMD160 749f943c37113cd594ac52ec4cedf7430131a469 libselinux-1.34.0.tgz 125574
+SHA256 2d3277e70829391804fe31933e41952ec8aec6bc2cbdf6648aa12e02e7d5d460 libselinux-1.34.0.tgz 125574
diff --git a/sys-libs/libselinux/libselinux-1.34.0.ebuild b/sys-libs/libselinux/libselinux-1.34.0.ebuild
new file mode 100644 (file)
index 0000000..5f6a078
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-1.34.0.ebuild,v 1.1 2007/02/15 05:23:51 pebenito Exp $
+
+IUSE=""
+
+inherit eutils multilib python
+
+#BUGFIX_PATCH="${FILESDIR}/libselinux-1.30.3.diff"
+
+SEPOL_VER="1.16"
+
+DESCRIPTION="SELinux userland library"
+HOMEPAGE="http://www.nsa.gov/selinux"
+SRC_URI="http://www.nsa.gov/selinux/archives/${P}.tgz"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+DEPEND="=sys-libs/libsepol-${SEPOL_VER}*"
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       [ ! -z "${BUGFIX_PATCH}" ] && epatch "${BUGFIX_PATCH}"
+
+       # fix up paths for multilib
+       sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" ${S}/src/Makefile \
+               || die "Fix for multilib LIBDIR failed."
+       sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" ${S}/src/Makefile \
+               || die "Fix for multilib SHLIBDIR failed."
+}
+
+src_compile() {
+       python_version
+       emake LDFLAGS="-fPIC ${LDFLAGS}" all || die
+       emake PYLIBVER="python${PYVER}" LDFLAGS="-fPIC ${LDFLAGS}" pywrap || die
+
+       # add compatability aliases to swig wrapper
+       cat ${FILESDIR}/compat.py >> ${S}/src/selinux.py || die
+}
+
+src_install() {
+       python_version
+       make DESTDIR="${D}" PYLIBVER="python${PYVER}" install install-pywrap || die
+}
+
+pkg_postinst() {
+       python_version
+       python_mod_optimize ${ROOT}usr/lib/python${PYVER}/site-packages
+}
+
+pkg_postrm() {
+       python_version
+       python_mod_cleanup ${ROOT}usr/lib/python${PYVER}/site-packages
+}
index cb4d0d17af048de67e34641da0a8a8ba7f4221a8..5524e84ebf2257f7b2b5e7588668c27a79000b6e 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sys-libs/libsemanage
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.13 2006/10/09 23:01:18 pebenito Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.14 2007/02/15 05:26:21 pebenito Exp $
+
+*libsemanage-1.10.0 (15 Feb 2007)
+
+  15 Feb 2007; Chris PeBenito <pebenito@gentoo.org>
+  +libsemanage-1.10.0.ebuild:
+  New upstream release.
 
   09 Oct 2006; Chris PeBenito <pebenito@gentoo.org>
   libsemanage-1.6.17-r1.ebuild:
diff --git a/sys-libs/libsemanage/files/digest-libsemanage-1.10.0 b/sys-libs/libsemanage/files/digest-libsemanage-1.10.0
new file mode 100644 (file)
index 0000000..414b68d
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 298d0b7ea2ddeaa4b18ba9e7f4de9949 libsemanage-1.10.0.tgz 155664
+RMD160 15257d8fddf1b7f4e42ef2d1b4fabff9143618fd libsemanage-1.10.0.tgz 155664
+SHA256 09719e56e2be6fcd747a76e84f4c722b78cf143558da7e0650c6a230f3e22fbe libsemanage-1.10.0.tgz 155664
diff --git a/sys-libs/libsemanage/libsemanage-1.10.0.ebuild b/sys-libs/libsemanage/libsemanage-1.10.0.ebuild
new file mode 100644 (file)
index 0000000..a980216
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/libsemanage-1.10.0.ebuild,v 1.1 2007/02/15 05:26:21 pebenito Exp $
+
+IUSE=""
+
+inherit eutils multilib python
+
+# BUGFIX_PATCH="${FILESDIR}/libsemanage-1.6.6.diff"
+
+SEPOL_VER="1.16"
+SELNX_VER="1.34"
+
+DESCRIPTION="SELinux kernel and policy management library"
+HOMEPAGE="http://www.nsa.gov/selinux"
+SRC_URI="http://www.nsa.gov/selinux/archives/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+DEPEND="=sys-libs/libsepol-${SEPOL_VER}*
+       =sys-libs/libselinux-${SELNX_VER}*"
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       [ ! -z "${BUGFIX_PATCH}" ] && epatch "${BUGFIX_PATCH}"
+
+       # fix up paths for multilib
+       sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" ${S}/src/Makefile \
+               || die "Fix for multilib LIBDIR failed."
+       sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" ${S}/src/Makefile \
+               || die "Fix for multilib SHLIBDIR failed."
+}
+
+src_compile() {
+       python_version
+       emake PYLIBVER="python${PYVER}" all pywrap || die
+}
+
+src_install() {
+       python_version
+       make DESTDIR="${D}" PYLIBVER="python${PYVER}" install install-pywrap
+
+       # remove config file.  the appropriate
+       # policy will install this file.
+       rm -fR ${D}/etc
+}
+
+pkg_postinst() {
+       python_version
+       python_mod_optimize ${ROOT}usr/lib/python${PYVER}/site-packages
+}
+
+pkg_postrm() {
+       python_version
+       python_mod_cleanup ${ROOT}usr/lib/python${PYVER}/site-packages
+}
index 060691f9028eb7849d6ec55495839fafd9688e8d..484fa38b9da6d3dbafa3dd7a48aca6ac5e482c79 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for sys-libs/libsepol
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.20 2006/10/09 22:56:37 pebenito Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.21 2007/02/15 05:21:54 pebenito Exp $
+
+*libsepol-1.16.0 (15 Feb 2007)
+
+  15 Feb 2007; Chris PeBenito <pebenito@gentoo.org> +libsepol-1.16.0.ebuild:
+  New upstream release.
 
   09 Oct 2006; Chris PeBenito <pebenito@gentoo.org> libsepol-1.12.28.ebuild:
   Stable to make repoman happy.
index 7d291ef967a13cbd644fee7dafa80b076d722a58..b500cdf332ca36db58f4bb85a671ef2d5d0dafec 100644 (file)
@@ -1 +1,3 @@
 MD5 7111064eb5a21c4d49f2e8d5dc97e278 libsepol-1.10.tgz 136309
+RMD160 43f9c4e2a9e115793276a39c2c79b43bafe09c66 libsepol-1.10.tgz 136309
+SHA256 88e33d9ed730a9d1f81851885296845822b07ba7b15ae967b7f15c93a9dc2c0e libsepol-1.10.tgz 136309
diff --git a/sys-libs/libsepol/files/digest-libsepol-1.16.0 b/sys-libs/libsepol/files/digest-libsepol-1.16.0
new file mode 100644 (file)
index 0000000..c54b16f
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 f40612cf2199c4d7157718ce3c2d1688 libsepol-1.16.0.tgz 181467
+RMD160 2696f1be38fd72c51d167bfed9c10418f0d650d7 libsepol-1.16.0.tgz 181467
+SHA256 b845411bb8cd14d552f40ac52c59beaa0485efd2221a18757ec9188ba8e2c2f8 libsepol-1.16.0.tgz 181467
diff --git a/sys-libs/libsepol/libsepol-1.16.0.ebuild b/sys-libs/libsepol/libsepol-1.16.0.ebuild
new file mode 100644 (file)
index 0000000..f0dbeec
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-1.16.0.ebuild,v 1.1 2007/02/15 05:21:54 pebenito Exp $
+
+IUSE=""
+
+inherit multilib eutils
+
+#BUGFIX_PATCH="${FILESDIR}/libsepol-1.12.5.diff"
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="http://www.nsa.gov/selinux"
+SRC_URI="http://www.nsa.gov/selinux/archives/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       [ ! -z "$BUGFIX_PATCH" ] && epatch "${BUGFIX_PATCH}"
+
+       # fix up paths for multilib
+       sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+               || die "Fix for multilib LIBDIR failed."
+       sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+               || die "Fix for multilib SHLIBDIR failed."
+}
+
+src_compile() {
+       emake || die
+}
+
+src_install() {
+       make DESTDIR="${D}" install
+}