www-client/firefox - Fix build install issues with pax-marking xpcshell
authorJory A. Pratt <anarchy@gentoo.org>
Sun, 14 Aug 2016 17:40:21 +0000 (12:40 -0500)
committerJory A. Pratt <anarchy@gentoo.org>
Sun, 14 Aug 2016 18:22:14 +0000 (13:22 -0500)
Signed-off-by: Jory A. Pratt <anarchy@gentoo.org>
www-client/firefox/firefox-48.0.ebuild

index c430b690c7125aa53cd794bc666ddcc196cbbf96..1672e26693007785e037cf3b46a5c397c094bd41 100644 (file)
@@ -256,6 +256,9 @@ src_compile() {
 src_install() {
        cd "${BUILD_OBJ_DIR}" || die
 
+       # Pax mark xpcshell for hardened support, only used for startupcache creation.
+       pax-mark m "${BUILD_OBJ_DIR}"/dist/bin/xpcshell
+
        # Add our default prefs for firefox
        cp "${FILESDIR}"/gentoo-default-prefs.js-1 \
                "${BUILD_OBJ_DIR}/dist/bin/browser/defaults/preferences/all-gentoo.js" \