dev-python/importlib_resources: bump to 1.3.1, introduces new deps
authorLouis Sautier <sbraz@gentoo.org>
Wed, 11 Mar 2020 12:50:15 +0000 (13:50 +0100)
committerLouis Sautier <sbraz@gentoo.org>
Wed, 11 Mar 2020 12:52:14 +0000 (13:52 +0100)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
dev-python/importlib_resources/Manifest
dev-python/importlib_resources/importlib_resources-1.3.1.ebuild [new file with mode: 0644]

index ee0d6e3634110a845641c8b0492598273b8145f8..791ac8e8978eb8a4a49ab0847d600c536c9984e1 100644 (file)
@@ -1 +1,2 @@
 DIST importlib_resources-1.0.2.tar.gz 23602 BLAKE2B 24c27b45ec56d3838b039baf2ebc1e0c5ec582d5cfdeb5cf26587255bf8b32aa1fcf43802cabca3b82b3ddec8cdf2616d10489c3c1aca77c9fa91af1f25ef9e7 SHA512 50bfc5130a2c9c9354efef1cd7132e805ed0f13467ba67172f83e11d907212bef3957aeef51fd904b73996c8280008d99c918637956a470448dfd67ef4807f82
+DIST importlib_resources-1.3.1.tar.gz 23683 BLAKE2B c5c759a0aca53294e4ab945d918ec4e9f5b8ffa19e7185c5ee6c3db1589a7979242cebbaccad37c0125cccbcf96deeb8a7ac77a5419fa1cca2d0fc0baaeb7df8 SHA512 28661fff19475d27caaa420244a4e2a1fe12ce525eaea4f9892fad5f50a1b991be8c9764c34c1ca0bcc840d49535a963f9784caab221848f0ce0e43b9991dd3d
diff --git a/dev-python/importlib_resources/importlib_resources-1.3.1.ebuild b/dev-python/importlib_resources/importlib_resources-1.3.1.ebuild
new file mode 100644 (file)
index 0000000..48478cf
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# This is a backport of Python 3.7's importlib.resources
+PYTHON_COMPAT=( pypy3 python{2_7,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="https://importlib-resources.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+       $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' -2)
+       $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
+       $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2)
+       $(python_gen_cond_dep 'dev-python/zipp[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
+       virtual/python-singledispatch[${PYTHON_USEDEP}]
+       virtual/python-typing[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       dev-python/toml[${PYTHON_USEDEP}]
+       >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx importlib_resources/docs dev-python/rst-linker
+
+python_compile() {
+       distutils-r1_python_compile
+       if ! python_is_python3; then
+               rm "${BUILD_DIR}/lib/importlib_resources/_py3.py" || die
+       fi
+}
+
+python_install() {
+       distutils-r1_python_install --skip-build
+}