dev-python/sphinxcontrib-github-alt: Build from pyproject.toml
authorMichał Górny <mgorny@gentoo.org>
Sun, 22 Dec 2019 12:44:58 +0000 (13:44 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 20 Feb 2020 09:36:26 +0000 (10:36 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1-r1.ebuild b/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1-r1.ebuild
new file mode 100644 (file)
index 0000000..e2c50ac
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="sphinxcontrib_github_alt"
+
+DESCRIPTION="Link to GitHub issues, pull requests, commits and users from Sphinx docs"
+HOMEPAGE="https://github.com/jupyter/sphinxcontrib_github_alt"
+SRC_URI="https://github.com/jupyter/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+BDEPEND=${RDEPEND}
+
+S="${WORKDIR}/${MY_PN}-${PV}"