dev-lang/php: add "coverage" USE flag to build with --enable-gcov.
authorMichael Orlitzky <mjo@gentoo.org>
Fri, 9 Dec 2016 14:18:52 +0000 (09:18 -0500)
committerMichael Orlitzky <mjo@gentoo.org>
Fri, 9 Dec 2016 16:12:29 +0000 (11:12 -0500)
We add three new revisions, one for each supported branch of PHP. The
new revisions have a "coverage" flag, which was chosen because a few
other packages in ::gentoo have decided on the same flag name. When
enabled, USE=coverage will pull in dev-util/lcov from the Linux Test
Project, and PHP will be built with --enable-gcov.

Since users won't be running code coverage reports on the PHP source
tree itself (at least not the one used by their package manager), this
is probably only useful for extension developers who would like to run
code coverage reports on the test suites for their extensions. It also
requires GCC to work, since lcov wraps GCC's gcov. Both of those
caveats have been mentioned in the USE flag description.

Gentoo-Bug: 542178

Package-Manager: portage-2.3.0

dev-lang/php/metadata.xml
dev-lang/php/php-5.6.28-r2.ebuild [moved from dev-lang/php/php-5.6.28-r1.ebuild with 99% similarity]
dev-lang/php/php-7.0.14-r1.ebuild [moved from dev-lang/php/php-7.0.14.ebuild with 99% similarity]
dev-lang/php/php-7.1.0-r3.ebuild [moved from dev-lang/php/php-7.1.0-r2.ebuild with 99% similarity]

index 66ecbe7d4a77c7c15b0f9d2725a84446fd922f82..64d6bb84b89156b3d75c4da0e696799a3c9f1f66 100644 (file)
@@ -7,6 +7,7 @@
        </maintainer>
        <use>
                <flag name="cli">Enable CLI SAPI</flag>
+               <flag name="coverage">Include gcov symbols for test coverage and lcov reports. Only useful for extension developers, and requires GCC.</flag>
                <flag name="embed">Enable embed SAPI</flag>
                <flag name="enchant">Add supports Enchant spelling library.</flag>
                <flag name="fileinfo">Add fileinfo extension support</flag>
similarity index 99%
rename from dev-lang/php/php-5.6.28-r1.ebuild
rename to dev-lang/php/php-5.6.28-r2.ebuild
index 735757389db378e74a6537ec7120b717347d8874..d0446a119ab4782062b102119ef1f0b536f57eae 100644 (file)
@@ -30,7 +30,7 @@ IUSE="${IUSE}
        threads"
 
 IUSE="${IUSE} acl bcmath berkdb bzip2 calendar cdb cjk
-       crypt +ctype curl debug
+       coverage crypt +ctype curl debug
        enchant exif frontbase +fileinfo +filter firebird
        flatfile ftp gd gdbm gmp +hash +iconv imap inifile
        intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit libressl
@@ -63,6 +63,7 @@ COMMON_DEPEND="
                media-libs/libpng:0=
                sys-libs/zlib
        ) )
+       coverage? ( dev-util/lcov )
        crypt? ( >=dev-libs/libmcrypt-2.4 )
        curl? ( >=net-misc/curl-7.10.5 )
        enchant? ( app-text/enchant )
@@ -301,6 +302,7 @@ src_configure() {
                $(use_enable bcmath bcmath)
                $(use_with bzip2 bz2 "${EPREFIX}/usr")
                $(use_enable calendar calendar)
+               $(use_enable coverage gcov)
                $(use_enable ctype ctype)
                $(use_with curl curl "${EPREFIX}/usr")
                $(use_enable xml dom)
similarity index 99%
rename from dev-lang/php/php-7.0.14.ebuild
rename to dev-lang/php/php-7.0.14-r1.ebuild
index ecc4bce83cd0d2742cb4c39e1632435aef1721ca..da9417192ca04cb8d0cec19517da944c6f4920ef 100644 (file)
@@ -30,7 +30,7 @@ IUSE="${IUSE}
        threads"
 
 IUSE="${IUSE} acl bcmath berkdb bzip2 calendar cdb cjk
-       crypt +ctype curl debug
+       coverage crypt +ctype curl debug
        enchant exif frontbase +fileinfo +filter firebird
        flatfile ftp gd gdbm gmp +hash +iconv imap inifile
        intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit libressl
@@ -63,6 +63,7 @@ COMMON_DEPEND="
                media-libs/libpng:0=
                sys-libs/zlib
        ) )
+       coverage? ( dev-util/lcov )
        crypt? ( >=dev-libs/libmcrypt-2.4 )
        curl? ( >=net-misc/curl-7.10.5 )
        enchant? ( app-text/enchant )
@@ -290,6 +291,7 @@ src_configure() {
                $(use_enable bcmath bcmath)
                $(use_with bzip2 bz2 "${EPREFIX}/usr")
                $(use_enable calendar calendar)
+               $(use_enable coverage gcov)
                $(use_enable ctype ctype)
                $(use_with curl curl "${EPREFIX}/usr")
                $(use_enable xml dom)
similarity index 99%
rename from dev-lang/php/php-7.1.0-r2.ebuild
rename to dev-lang/php/php-7.1.0-r3.ebuild
index d0298d28bff5e20588c934b40854303ebded0770..2eca60ab0540a516697e97dcc24e92e94baedaf0 100644 (file)
@@ -30,7 +30,7 @@ IUSE="${IUSE}
        threads"
 
 IUSE="${IUSE} acl bcmath berkdb bzip2 calendar cdb cjk
-       crypt +ctype curl debug
+       coverage crypt +ctype curl debug
        enchant exif frontbase +fileinfo +filter firebird
        flatfile ftp gd gdbm gmp +hash +iconv imap inifile
        intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit libressl
@@ -63,6 +63,7 @@ COMMON_DEPEND="
                media-libs/libpng:0=
                sys-libs/zlib
        ) )
+       coverage? ( dev-util/lcov )
        crypt? ( >=dev-libs/libmcrypt-2.4 )
        curl? ( >=net-misc/curl-7.10.5 )
        enchant? ( app-text/enchant )
@@ -264,6 +265,7 @@ src_configure() {
                $(use_enable bcmath bcmath)
                $(use_with bzip2 bz2 "${EPREFIX}/usr")
                $(use_enable calendar calendar)
+               $(use_enable coverage gcov)
                $(use_enable ctype ctype)
                $(use_with curl curl "${EPREFIX}/usr")
                $(use_enable xml dom)