gnome-base/gnome-control-center: Fix GCC 10 / -fno-common
authorDavid Seifert <soap@gentoo.org>
Wed, 26 Feb 2020 19:46:18 +0000 (20:46 +0100)
committerDavid Seifert <soap@gentoo.org>
Wed, 26 Feb 2020 19:46:18 +0000 (20:46 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
gnome-base/gnome-control-center/files/gnome-control-center-3.32.2-fix-gcc10-fno-common.patch [new file with mode: 0644]
gnome-base/gnome-control-center/gnome-control-center-3.32.2.ebuild

diff --git a/gnome-base/gnome-control-center/files/gnome-control-center-3.32.2-fix-gcc10-fno-common.patch b/gnome-base/gnome-control-center/files/gnome-control-center-3.32.2-fix-gcc10-fno-common.patch
new file mode 100644 (file)
index 0000000..b0a7a70
--- /dev/null
@@ -0,0 +1,26 @@
+From 901ef8b0ff2b05692cbaa119097f70615ea77ed4 Mon Sep 17 00:00:00 2001
+From: Mike Gorse <mgorse@suse.com>
+Date: Thu, 9 Jan 2020 21:34:12 +0000
+Subject: [PATCH] Thunderbolt: make BoltError enum a typedef
+
+Fixes error when compiled with -fno-common
+---
+ panels/thunderbolt/bolt-error.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/panels/thunderbolt/bolt-error.h b/panels/thunderbolt/bolt-error.h
+index 39b3eee98..7d3823d35 100644
+--- a/panels/thunderbolt/bolt-error.h
++++ b/panels/thunderbolt/bolt-error.h
+@@ -31,7 +31,7 @@ G_BEGIN_DECLS
+  *
+  * Error codes used inside Bolt.
+  */
+-enum {
++typedef enum {
+   BOLT_ERROR_FAILED = 0,
+   BOLT_ERROR_UDEV,
+   BOLT_ERROR_NOKEY,
+-- 
+2.24.1
+
index cac1b28a467122a35c25866b6a70c4e21155caf0..70a11f092400778f490e20b444d37b6bf87b722f 100644 (file)
@@ -123,6 +123,8 @@ PATCHES=(
        # https://bugzilla.gnome.org/686840, 697478, 700145
        # Fix some absolute paths to be appropriate for Gentoo
        "${WORKDIR}"/patches/
+
+       "${FILESDIR}"/${PN}-3.32.2-fix-gcc10-fno-common.patch # fixed in 3.35.90
 )
 
 src_configure() {