media-video/griffith: Remove last-rited pkg
authorMichał Górny <mgorny@gentoo.org>
Sat, 23 May 2020 09:44:01 +0000 (11:44 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 23 May 2020 09:44:01 +0000 (11:44 +0200)
Closes: https://bugs.gentoo.org/708168
Signed-off-by: Michał Górny <mgorny@gentoo.org>
media-video/griffith/Manifest [deleted file]
media-video/griffith/files/0.10-fix_lib_path.patch [deleted file]
media-video/griffith/files/griffith-0.13-validators.patch [deleted file]
media-video/griffith/griffith-0.13-r3.ebuild [deleted file]
media-video/griffith/metadata.xml [deleted file]
profiles/package.mask

diff --git a/media-video/griffith/Manifest b/media-video/griffith/Manifest
deleted file mode 100644 (file)
index 181187c..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST griffith-0.13.tar.gz 1565903 BLAKE2B d3d806ef2a7cef76ce548e3ad785e96938447cb6425ac95fdbb4b5ae233adb2aeb4a274aa24c9e502607bc1287ea30ce8806cb1608fc194531757943e499b0e7 SHA512 dc8117b1a89253a87eb303c5229e6cdffde26b52de9ac4a3409dcc3f6dca64105f13a98cace225a932aefb2d620e828eea66bae57f40328b7ee3c06a944f0bed
-DIST griffith-extra-artwork-0.9.4.tar.gz 124008 BLAKE2B 992f8e4995d0465e891eacfe601eead2323754c60ad0c0a96ea9568dbecf5790039f58212e8a115f382532e1787e4db267b1259ac91de40728f7911f6b2178ae SHA512 09e912b4511c5c4a7b501d9a8f98223d20e58574e667cdb759e66f743cce14b45cce8bf0f9502ff2aacfc09e7a7b37966a887205a74a6e028b832703a65a2734
diff --git a/media-video/griffith/files/0.10-fix_lib_path.patch b/media-video/griffith/files/0.10-fix_lib_path.patch
deleted file mode 100644 (file)
index 9c918b2..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: lib/initialize.py
-===================================================================
---- a/lib/initialize.py
-+++ b/lib/initialize.py
-@@ -73,7 +73,7 @@ def locations(self, home_dir):
-             os.environ['LANG'] = lang
-     elif os.name == 'posix':
--        locations['share'] = os.path.abspath(os.path.join(locations['lib'], '..'))
-+        locations['share'] = os.path.abspath(os.path.join(locations['lib'], '../../share/griffith/'))
-         locations['glade'] = os.path.join(locations['share'], 'glade')
-         locations['i18n']  = os.path.abspath(os.path.join(locations['share'], '..', 'locale'))
-         if not os.path.isdir(locations['i18n']):
diff --git a/media-video/griffith/files/griffith-0.13-validators.patch b/media-video/griffith/files/griffith-0.13-validators.patch
deleted file mode 100644 (file)
index 9c39fee..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
---- griffith-0.13/lib/db/validators.py
-+++ griffith-0.13/lib/db/validators.py
-@@ -23,7 +23,13 @@
- import logging
--from sqlalchemy.orm.interfaces import AttributeExtension, InstrumentationManager
-+from sqlalchemy.orm.interfaces import AttributeExtension
-+try:
-+    # sql alchemy 0.8 (and above)
-+    from sqlalchemy.ext.instrumentation import InstrumentationManager
-+except:
-+    # sql alchemy 0.7
-+    from sqlalchemy.orm.interfaces import InstrumentationManager
- from sqlalchemy.orm import ColumnProperty
- from sqlalchemy.types import String
diff --git a/media-video/griffith/griffith-0.13-r3.ebuild b/media-video/griffith/griffith-0.13-r3.ebuild
deleted file mode 100644 (file)
index d606fd8..0000000
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE='sqlite'
-
-inherit python-single-r1
-
-ARTWORK_PV="0.9.4"
-
-DESCRIPTION="Movie collection manager"
-HOMEPAGE="http://www.griffith.cc/"
-SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz
-       https://dev.gentoo.org/~hwoarang/distfiles/${PN}-extra-artwork-${ARTWORK_PV}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
-       ${PYTHON_DEPS}
-       gnome-base/libglade[${PYTHON_SINGLE_USEDEP}]
-       $(python_gen_cond_dep '
-               dev-python/pillow[${PYTHON_MULTI_USEDEP}]
-               >=dev-python/pygtk-2.6.1:2[${PYTHON_MULTI_USEDEP}]
-               dev-python/pygobject:2[${PYTHON_MULTI_USEDEP}]
-               >=dev-python/sqlalchemy-0.5.2[${PYTHON_MULTI_USEDEP}]
-               >=dev-python/reportlab-1.19[${PYTHON_MULTI_USEDEP}]
-       ')"
-DEPEND="${RDEPEND}
-       doc? ( app-text/docbook2X )"
-
-PATCHES=(
-       "${FILESDIR}/0.10-fix_lib_path.patch"
-       "${FILESDIR}/griffith-0.13-validators.patch"
-)
-
-pkg_setup() {
-       python-single-r1_pkg_setup
-}
-
-src_prepare() {
-       use doc || { sed -i -e '/docs/d' Makefile || die ; }
-       sed -i \
-               -e 's#/pl/#/pl.UTF-8/#' \
-               "${S}"/docs/pl/Makefile || die "sed failed"
-
-       sed -i \
-               -e 's/ISO-8859-1/UTF-8/' \
-               "${S}"/lib/gconsole.py || die "sed failed"
-
-       default
-}
-
-src_compile() {
-       # Nothing to compile and default `emake` spews an error message
-       true
-}
-
-src_install() {
-       if ! use doc ; then
-               sed -i -e '/docs/d' Makefile || die
-       fi
-
-       emake \
-               LIBDIR="${D}/usr/$(get_libdir)/griffith" \
-               DESTDIR="${D}" DOC2MAN=docbook2man.pl install
-       dodoc AUTHORS ChangeLog README THANKS TODO NEWS TRANSLATORS
-
-       cd "${WORKDIR}/${PN}-extra-artwork-${ARTWORK_PV}/" || die
-       emake DESTDIR="${D}" install
-       # This carries over from -0.13 but appears to have no effect.
-       python_optimize "${ED}"/usr/share/${PN}
-}
-
-pkg_postinst() {
-       einfo
-       einfo "${PN} can make use of the following optional dependencies"
-       einfo "dev-python/chardet: CSV file encoding detections"
-       einfo "dev-python/mysql-python: Python interface for MySQL connectivity"
-       einfo ">=dev-python/psycopg-2.4: Python interface for PostgreSQL connectivity"
-       einfo
-}
diff --git a/media-video/griffith/metadata.xml b/media-video/griffith/metadata.xml
deleted file mode 100644 (file)
index ec78ebb..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-  <maintainer type="project">
-    <email>media-video@gentoo.org</email>
-    <name>Gentoo Video project</name>
-  </maintainer>
-  <upstream>
-    <remote-id type="launchpad">griffith</remote-id>
-  </upstream>
-</pkgmetadata>
index 1aa544745500d350812dbc915825b6ca927c54ff..15d335bfc49fdaa88c0ae1fe9dd87c62e545513a 100644 (file)
@@ -498,12 +498,6 @@ dev-python/demjson
 # Removal in 30 days. Bug #718832
 dev-python/flask-bootstrap
 
-# Michał Górny <mgorny@gentoo.org> (2020-04-20)
-# Effectively unmaintained.  Stuck on Python 2 and pygtk.  Last bumped
-# in 2014.
-# Removal in 30 days.  Bug #708168.
-media-video/griffith
-
 # Michael Orlitzky <mjo@gentoo.org> (2020-04-19)
 # Stuck on Python 3.6, support for which already required
 # backporting patches to a release from 2014. Upstream's git