net-analyzer/zabbix: bump to 4.0.19 and 4.4.7
authorMiroslav Šulc <fordfrog@gentoo.org>
Mon, 30 Mar 2020 08:30:08 +0000 (10:30 +0200)
committerMiroslav Šulc <fordfrog@gentoo.org>
Mon, 30 Mar 2020 08:30:08 +0000 (10:30 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
net-analyzer/zabbix/Manifest
net-analyzer/zabbix/zabbix-4.0.19.ebuild [new file with mode: 0644]
net-analyzer/zabbix/zabbix-4.4.7.ebuild [new file with mode: 0644]

index 4f50f6f2d42f65cb90896cfd704d25312c0f6a92..6cd40a58fc1abb6e4094bcd6de3316fdfa448332 100644 (file)
@@ -1,3 +1,5 @@
 DIST zabbix-3.0.30.tar.gz 14700686 BLAKE2B 9caa772c8dfdd53411bc996b8c97dce7c24853ea1049fe3cb71048c089105af5c7d1cf51071d91d1d2a98113181e9977a1ca3b4304e42a4a2f8bb0b87cd725b8 SHA512 6e60c9e5570aa69e1d52f005094eda1618aafc6d7ee831d4e5dc26f64b0691e2d9e494845fd36d22b049175776057fca28142da31d5e8e06d6c6f3e003bde3a3
 DIST zabbix-4.0.18.tar.gz 17200784 BLAKE2B 00c447459518d4c3a600e82f42f2ae14bcda6d8a933eb25a31fb00951f556355925e90960b76e273c2cc08a83b476e7c1a98b2e94aa4c23363fd639d4b199ac5 SHA512 c686611f60242cb2bef408bacbd71b7f3e88ad01b5ac9c34566c36812c9469c85c2388a9efd2ded5b329a3ffa7ec474845f2bac4e100e66b80078823c276cecb
+DIST zabbix-4.0.19.tar.gz 17211769 BLAKE2B 1f7ac3fb195c35a41fae84a2b9a7985bee49664df8469ef7a14b9e264348447e5d5822fdc05feca4041ca57e74d15bc8b5cae262024fc5dca7749af263224d2d SHA512 c279af3d8b1b9125420d65e4e20a8892f9531a345e1f0046214fa14ab6204d535fd0cb672b5f3c6b5e325b7d8ff44e317bde58611f4bef9d89aba70851326daf
 DIST zabbix-4.4.6.tar.gz 19371211 BLAKE2B b63d946f360c529bfc32070e2907cdfada34ee3615c24c6a65ada7379e2ad65ff8e1d182ff9b59e11c844103cb608aafeab0f2bc6bb97fc1a31183214a6df01e SHA512 f9e84872f0210e497261462de95e9096391fc74bee6fd511087825fcfdd8f363003bd090e01a8a092a69ef1f01c4dd31d623f5321cf77dbced0bd337fb91682c
+DIST zabbix-4.4.7.tar.gz 19413652 BLAKE2B 3c7d55a64f8d0e94d7fca3d088bb40592f56ffd5ca8025fb2cdd82ae7946bca1449b354e74cc3e50a6fca9b0bc2b46cf995b74d31d4b462f3d0b4be734f7c19b SHA512 2b96771bb555fae3df67665ac2e47c94662b071eb97c943d59b8f1fc7d31e2bf349c551a0015c6e239321f069b3ab87373c397a023cbff3daad8bd310d11fb6a
diff --git a/net-analyzer/zabbix/zabbix-4.0.19.ebuild b/net-analyzer/zabbix/zabbix-4.0.19.ebuild
new file mode 100644 (file)
index 0000000..2821011
--- /dev/null
@@ -0,0 +1,350 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# needed to make webapp-config dep optional
+WEBAPP_OPTIONAL="yes"
+inherit flag-o-matic webapp java-pkg-opt-2 user systemd toolchain-funcs
+
+DESCRIPTION="ZABBIX is software for monitoring of your applications, network and servers"
+HOMEPAGE="https://www.zabbix.com/"
+MY_P=${P/_/}
+MY_PV=${PV/_/}
+SRC_URI="mirror://sourceforge/project/zabbix/ZABBIX%20Latest%20Stable/${PV}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+WEBAPP_MANUAL_SLOT="yes"
+KEYWORDS="~amd64 ~x86"
+IUSE="+agent java curl frontend ipv6 xmpp ldap libxml2 mysql openipmi oracle +postgres proxy server ssh ssl snmp sqlite odbc static"
+REQUIRED_USE="|| ( agent frontend proxy server )
+       proxy? ( ^^ ( mysql oracle postgres sqlite odbc ) )
+       server? ( ^^ ( mysql oracle postgres odbc ) )
+       static? ( !oracle !snmp )"
+
+COMMON_DEPEND="
+       curl? ( net-misc/curl )
+       java? ( >=virtual/jdk-1.8:* )
+       ldap? (
+               =dev-libs/cyrus-sasl-2*
+               net-libs/gnutls
+               net-nds/openldap
+       )
+       libxml2? ( dev-libs/libxml2 )
+       mysql? ( dev-db/mysql-connector-c )
+       odbc? ( dev-db/unixODBC )
+       openipmi? ( sys-libs/openipmi )
+       oracle? ( dev-db/oracle-instantclient-basic )
+       postgres? ( dev-db/postgresql:* )
+       proxy?  ( sys-libs/zlib )
+       server? (
+               dev-libs/libevent
+               sys-libs/zlib
+       )
+       snmp? ( net-analyzer/net-snmp )
+       sqlite? ( dev-db/sqlite )
+       ssh? ( net-libs/libssh2 )
+       ssl? ( dev-libs/openssl:=[-bindist] )
+       xmpp? ( dev-libs/iksemel )
+"
+
+RDEPEND="${COMMON_DEPEND}
+       java? ( >=virtual/jre-1.8:* )
+       mysql? ( virtual/mysql )
+       proxy? ( net-analyzer/fping[suid] )
+       server? (
+               app-admin/webapp-config
+               dev-libs/libevent
+               dev-libs/libpcre
+               net-analyzer/fping[suid]
+       )
+       frontend? (
+               app-admin/webapp-config
+               dev-lang/php:*[bcmath,ctype,sockets,gd,truetype,xml,session,xmlreader,xmlwriter,nls,sysvipc,unicode]
+               media-libs/gd[png]
+               virtual/httpd-php:*
+               mysql? ( dev-lang/php[mysqli] )
+               odbc? ( dev-lang/php[odbc] )
+               oracle? ( dev-lang/php[oci8-instant-client] )
+               postgres? ( dev-lang/php[postgres] )
+               sqlite? ( dev-lang/php[sqlite] )
+       )
+"
+DEPEND="${COMMON_DEPEND}
+       static? (
+               curl? ( net-misc/curl[static-libs] )
+               ldap? (
+                       =dev-libs/cyrus-sasl-2*[static-libs]
+                       net-libs/gnutls[static-libs]
+                       net-nds/openldap[static-libs]
+               )
+               libxml2? ( dev-libs/libxml2[static-libs] )
+               mysql? ( dev-db/mysql-connector-c[static-libs] )
+               odbc? ( dev-db/unixODBC[static-libs] )
+               postgres? ( dev-db/postgresql:*[static-libs] )
+               sqlite? ( dev-db/sqlite[static-libs] )
+               ssh? ( net-libs/libssh2 )
+       )
+"
+BDEPEND="
+       virtual/pkgconfig
+"
+
+PATCHES=(
+       "${FILESDIR}/${P}-modulepathfix.patch"
+       "${FILESDIR}/${PN}-3.0.30-security-disable-PidFile.patch"
+)
+
+S=${WORKDIR}/${MY_P}
+
+ZABBIXJAVA_BASE="opt/zabbix_java"
+
+pkg_setup() {
+       if use oracle; then
+               if [ -z "${ORACLE_HOME}" ]; then
+                       eerror
+                       eerror "The environment variable ORACLE_HOME must be set"
+                       eerror "and point to the correct location."
+                       eerror "It looks like you don't have Oracle installed."
+                       eerror
+                       die "Environment variable ORACLE_HOME is not set"
+               fi
+               if has_version 'dev-db/oracle-instantclient-basic'; then
+                       ewarn
+                       ewarn "Please ensure you have a full install of the Oracle client."
+                       ewarn "dev-db/oracle-instantclient* is NOT sufficient."
+                       ewarn
+               fi
+       fi
+
+       if use frontend; then
+               webapp_pkg_setup
+       fi
+
+       enewgroup zabbix
+       enewuser zabbix -1 -1 /var/lib/zabbix/home zabbix
+
+       java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+       default
+}
+
+src_configure() {
+       econf \
+               $(use_enable agent) \
+               $(use_enable ipv6) \
+               $(use_enable java) \
+               $(use_enable proxy) \
+               $(use_enable server) \
+               $(use_enable static) \
+               $(use_with curl libcurl) \
+               $(use_with ldap) \
+               $(use_with libxml2) \
+               $(use_with mysql) \
+               $(use_with odbc unixodbc) \
+               $(use_with openipmi openipmi) \
+               $(use_with oracle) \
+               $(use_with postgres postgresql) \
+               $(use_with snmp net-snmp) \
+               $(use_with sqlite sqlite3) \
+               $(use_with ssh ssh2) \
+               $(use_with ssl openssl) \
+               $(use_with xmpp jabber)
+}
+
+src_compile() {
+       if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
+               emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
+       fi
+}
+
+src_install() {
+       local dirs=(
+               /etc/zabbix
+               /var/lib/zabbix
+               /var/lib/zabbix/home
+               /var/lib/zabbix/scripts
+               /var/lib/zabbix/alertscripts
+               /var/lib/zabbix/externalscripts
+               /var/log/zabbix
+       )
+
+       for dir in "${dirs[@]}"; do
+               dodir "${dir}"
+               keepdir "${dir}"
+       done
+
+       if use server; then
+               insinto /etc/zabbix
+               doins "${S}"/conf/zabbix_server.conf
+               fperms 0640 /etc/zabbix/zabbix_server.conf
+               fowners root:zabbix /etc/zabbix/zabbix_server.conf
+
+               newinitd "${FILESDIR}"/zabbix-server.init zabbix-server
+
+               dosbin src/zabbix_server/zabbix_server
+
+               insinto /usr/share/zabbix
+               doins -r "${S}"/database/
+
+               systemd_dounit "${FILESDIR}"/zabbix-server.service
+               systemd_newtmpfilesd "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
+       fi
+
+       if use proxy; then
+               insinto /etc/zabbix
+               doins "${S}"/conf/zabbix_proxy.conf
+               fperms 0640 /etc/zabbix/zabbix_proxy.conf
+               fowners root:zabbix /etc/zabbix/zabbix_proxy.conf
+
+               newinitd "${FILESDIR}"/zabbix-proxy.init zabbix-proxy
+
+               dosbin src/zabbix_proxy/zabbix_proxy
+
+               insinto /usr/share/zabbix
+               doins -r "${S}"/database/
+
+               systemd_dounit "${FILESDIR}"/zabbix-proxy.service
+               systemd_newtmpfilesd "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
+       fi
+
+       if use agent; then
+               insinto /etc/zabbix
+               doins "${S}"/conf/zabbix_agentd.conf
+               fperms 0640 /etc/zabbix/zabbix_agentd.conf
+               fowners root:zabbix /etc/zabbix/zabbix_agentd.conf
+
+               newinitd "${FILESDIR}"/zabbix-agentd.init zabbix-agentd
+
+               dosbin src/zabbix_agent/zabbix_agentd
+               dobin \
+                       src/zabbix_sender/zabbix_sender \
+                       src/zabbix_get/zabbix_get
+
+               systemd_dounit "${FILESDIR}"/zabbix-agentd.service
+               systemd_newtmpfilesd "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
+       fi
+
+       fowners root:zabbix /etc/zabbix
+       fowners zabbix:zabbix \
+               /var/lib/zabbix \
+               /var/lib/zabbix/home \
+               /var/lib/zabbix/scripts \
+               /var/lib/zabbix/alertscripts \
+               /var/lib/zabbix/externalscripts \
+               /var/log/zabbix
+       fperms 0750 \
+               /etc/zabbix \
+               /var/lib/zabbix \
+               /var/lib/zabbix/home \
+               /var/lib/zabbix/scripts \
+               /var/lib/zabbix/alertscripts \
+               /var/lib/zabbix/externalscripts \
+               /var/log/zabbix
+
+       dodoc README INSTALL NEWS ChangeLog \
+               conf/zabbix_agentd.conf \
+               conf/zabbix_proxy.conf \
+               conf/zabbix_agentd/userparameter_examples.conf \
+               conf/zabbix_agentd/userparameter_mysql.conf \
+               conf/zabbix_server.conf
+
+       if use frontend; then
+               webapp_src_preinst
+               cp -R frontends/php/* "${D}/${MY_HTDOCSDIR}"
+               webapp_configfile \
+                       "${MY_HTDOCSDIR}"/include/db.inc.php \
+                       "${MY_HTDOCSDIR}"/include/config.inc.php
+               webapp_src_install
+       fi
+
+       if use java; then
+               dodir \
+                       /${ZABBIXJAVA_BASE} \
+                       /${ZABBIXJAVA_BASE}/bin \
+                       /${ZABBIXJAVA_BASE}/lib
+               keepdir /${ZABBIXJAVA_BASE}
+               exeinto /${ZABBIXJAVA_BASE}/bin
+               doexe src/zabbix_java/bin/zabbix-java-gateway-${MY_PV}.jar
+               exeinto /${ZABBIXJAVA_BASE}/lib
+               doexe \
+                       src/zabbix_java/lib/logback-classic-0.9.27.jar \
+                       src/zabbix_java/lib/logback-console.xml \
+                       src/zabbix_java/lib/logback-core-0.9.27.jar \
+                       src/zabbix_java/lib/logback.xml \
+                       src/zabbix_java/lib/android-json-4.3_r3.1.jar \
+                       src/zabbix_java/lib/slf4j-api-1.6.1.jar
+               newinitd "${FILESDIR}"/zabbix-jmx-proxy.init zabbix-jmx-proxy
+               newconfd "${FILESDIR}"/zabbix-jmx-proxy.conf zabbix-jmx-proxy
+       fi
+}
+
+pkg_postinst() {
+       if use server || use proxy ; then
+               elog
+               elog "You may need to configure your database for Zabbix"
+               elog "if you have not already done so."
+               elog
+
+               zabbix_homedir=$(egethome zabbix)
+               if [ -n "${zabbix_homedir}" ] && \
+                  [ "${zabbix_homedir}" != "/var/lib/zabbix/home" ]; then
+                       ewarn
+                       ewarn "The user 'zabbix' should have his homedir changed"
+                       ewarn "to /var/lib/zabbix/home if you want to use"
+                       ewarn "custom alert scripts."
+                       ewarn
+                       ewarn "A real homedir might be needed for configfiles"
+                       ewarn "for custom alert scripts (e.g. ~/.sendxmpprc when"
+                       ewarn "using sendxmpp for Jabber alerts)."
+                       ewarn
+                       ewarn "To change the homedir use:"
+                       ewarn "  usermod -d /var/lib/zabbix/home zabbix"
+                       ewarn
+               fi
+       fi
+
+       if use server; then
+               elog
+               elog "For distributed monitoring you have to run:"
+               elog
+               elog "zabbix_server -n <nodeid>"
+               elog
+               elog "This will convert database data for use with Node ID"
+               elog "and also adds a local node."
+               elog
+       fi
+
+       elog "--"
+       elog
+       elog "You may need to add these lines to /etc/services:"
+       elog
+       elog "zabbix-agent     10050/tcp Zabbix Agent"
+       elog "zabbix-agent     10050/udp Zabbix Agent"
+       elog "zabbix-trapper   10051/tcp Zabbix Trapper"
+       elog "zabbix-trapper   10051/udp Zabbix Trapper"
+       elog
+
+       if use server || use proxy ; then
+               # check for fping
+               fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
+               case "${fping_perms}" in
+                       4[157][157][157])
+                               ;;
+                       *)
+                               ewarn
+                               ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
+                               ewarn "you have to make /usr/sbin/fping setuid root and executable"
+                               ewarn "by everyone. Run the following command to fix it:"
+                               ewarn
+                               ewarn "  chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
+                               ewarn
+                               ewarn "Please be aware that this might impose a security risk,"
+                               ewarn "depending on the code quality of fping."
+                               ewarn
+                               ;;
+               esac
+       fi
+}
diff --git a/net-analyzer/zabbix/zabbix-4.4.7.ebuild b/net-analyzer/zabbix/zabbix-4.4.7.ebuild
new file mode 100644 (file)
index 0000000..8d40304
--- /dev/null
@@ -0,0 +1,347 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# needed to make webapp-config dep optional
+WEBAPP_OPTIONAL="yes"
+inherit flag-o-matic webapp java-pkg-opt-2 user systemd toolchain-funcs
+
+DESCRIPTION="ZABBIX is software for monitoring of your applications, network and servers"
+HOMEPAGE="https://www.zabbix.com/"
+MY_P=${P/_/}
+MY_PV=${PV/_/}
+SRC_URI="mirror://sourceforge/project/zabbix/ZABBIX%20Latest%20Stable/${PV}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+WEBAPP_MANUAL_SLOT="yes"
+KEYWORDS="~amd64 ~x86"
+IUSE="+agent java curl frontend ipv6 ldap libxml2 mysql openipmi oracle +postgres proxy server ssh ssl snmp sqlite odbc static"
+REQUIRED_USE="|| ( agent frontend proxy server )
+       proxy? ( ^^ ( mysql oracle postgres sqlite odbc ) )
+       server? ( ^^ ( mysql oracle postgres odbc ) )
+       static? ( !oracle !snmp )"
+
+COMMON_DEPEND="
+       curl? ( net-misc/curl )
+       java? ( >=virtual/jdk-1.8:* )
+       ldap? (
+               =dev-libs/cyrus-sasl-2*
+               net-libs/gnutls
+               net-nds/openldap
+       )
+       libxml2? ( dev-libs/libxml2 )
+       mysql? ( dev-db/mysql-connector-c )
+       odbc? ( dev-db/unixODBC )
+       openipmi? ( sys-libs/openipmi )
+       oracle? ( dev-db/oracle-instantclient-basic )
+       postgres? ( dev-db/postgresql:* )
+       proxy?  ( sys-libs/zlib )
+       server? (
+               dev-libs/libevent
+               sys-libs/zlib
+       )
+       snmp? ( net-analyzer/net-snmp )
+       sqlite? ( dev-db/sqlite )
+       ssh? ( net-libs/libssh2 )
+       ssl? ( dev-libs/openssl:=[-bindist] )
+"
+
+RDEPEND="${COMMON_DEPEND}
+       java? ( >=virtual/jre-1.8:* )
+       mysql? ( virtual/mysql )
+       proxy? ( net-analyzer/fping[suid] )
+       server? (
+               app-admin/webapp-config
+               dev-libs/libevent
+               dev-libs/libpcre
+               net-analyzer/fping[suid]
+       )
+       frontend? (
+               app-admin/webapp-config
+               dev-lang/php:*[bcmath,ctype,sockets,gd,truetype,xml,session,xmlreader,xmlwriter,nls,sysvipc,unicode]
+               media-libs/gd[png]
+               virtual/httpd-php:*
+               mysql? ( dev-lang/php[mysqli] )
+               odbc? ( dev-lang/php[odbc] )
+               oracle? ( dev-lang/php[oci8-instant-client] )
+               postgres? ( dev-lang/php[postgres] )
+               sqlite? ( dev-lang/php[sqlite] )
+       )
+"
+DEPEND="${COMMON_DEPEND}
+       static? (
+               curl? ( net-misc/curl[static-libs] )
+               ldap? (
+                       =dev-libs/cyrus-sasl-2*[static-libs]
+                       net-libs/gnutls[static-libs]
+                       net-nds/openldap[static-libs]
+               )
+               libxml2? ( dev-libs/libxml2[static-libs] )
+               mysql? ( dev-db/mysql-connector-c[static-libs] )
+               odbc? ( dev-db/unixODBC[static-libs] )
+               postgres? ( dev-db/postgresql:*[static-libs] )
+               sqlite? ( dev-db/sqlite[static-libs] )
+               ssh? ( net-libs/libssh2 )
+       )
+"
+BDEPEND="
+       virtual/pkgconfig
+"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-4.0.18-modulepathfix.patch"
+       "${FILESDIR}/${PN}-3.0.30-security-disable-PidFile.patch"
+)
+
+S=${WORKDIR}/${MY_P}
+
+ZABBIXJAVA_BASE="opt/zabbix_java"
+
+pkg_setup() {
+       if use oracle; then
+               if [ -z "${ORACLE_HOME}" ]; then
+                       eerror
+                       eerror "The environment variable ORACLE_HOME must be set"
+                       eerror "and point to the correct location."
+                       eerror "It looks like you don't have Oracle installed."
+                       eerror
+                       die "Environment variable ORACLE_HOME is not set"
+               fi
+               if has_version 'dev-db/oracle-instantclient-basic'; then
+                       ewarn
+                       ewarn "Please ensure you have a full install of the Oracle client."
+                       ewarn "dev-db/oracle-instantclient* is NOT sufficient."
+                       ewarn
+               fi
+       fi
+
+       if use frontend; then
+               webapp_pkg_setup
+       fi
+
+       enewgroup zabbix
+       enewuser zabbix -1 -1 /var/lib/zabbix/home zabbix
+
+       java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+       default
+}
+
+src_configure() {
+       econf \
+               $(use_enable agent) \
+               $(use_enable ipv6) \
+               $(use_enable java) \
+               $(use_enable proxy) \
+               $(use_enable server) \
+               $(use_enable static) \
+               $(use_with curl libcurl) \
+               $(use_with ldap) \
+               $(use_with libxml2) \
+               $(use_with mysql) \
+               $(use_with odbc unixodbc) \
+               $(use_with openipmi openipmi) \
+               $(use_with oracle) \
+               $(use_with postgres postgresql) \
+               $(use_with snmp net-snmp) \
+               $(use_with sqlite sqlite3) \
+               $(use_with ssh ssh2) \
+               $(use_with ssl openssl)
+}
+
+src_compile() {
+       if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
+               emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
+       fi
+}
+
+src_install() {
+       local dirs=(
+               /etc/zabbix
+               /var/lib/zabbix
+               /var/lib/zabbix/home
+               /var/lib/zabbix/scripts
+               /var/lib/zabbix/alertscripts
+               /var/lib/zabbix/externalscripts
+               /var/log/zabbix
+       )
+
+       for dir in "${dirs[@]}"; do
+               dodir "${dir}"
+               keepdir "${dir}"
+       done
+
+       if use server; then
+               insinto /etc/zabbix
+               doins "${S}"/conf/zabbix_server.conf
+               fperms 0640 /etc/zabbix/zabbix_server.conf
+               fowners root:zabbix /etc/zabbix/zabbix_server.conf
+
+               newinitd "${FILESDIR}"/zabbix-server.init zabbix-server
+
+               dosbin src/zabbix_server/zabbix_server
+
+               insinto /usr/share/zabbix
+               doins -r "${S}"/database/
+
+               systemd_dounit "${FILESDIR}"/zabbix-server.service
+               systemd_newtmpfilesd "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
+       fi
+
+       if use proxy; then
+               insinto /etc/zabbix
+               doins "${S}"/conf/zabbix_proxy.conf
+               fperms 0640 /etc/zabbix/zabbix_proxy.conf
+               fowners root:zabbix /etc/zabbix/zabbix_proxy.conf
+
+               newinitd "${FILESDIR}"/zabbix-proxy.init zabbix-proxy
+
+               dosbin src/zabbix_proxy/zabbix_proxy
+
+               insinto /usr/share/zabbix
+               doins -r "${S}"/database/
+
+               systemd_dounit "${FILESDIR}"/zabbix-proxy.service
+               systemd_newtmpfilesd "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
+       fi
+
+       if use agent; then
+               insinto /etc/zabbix
+               doins "${S}"/conf/zabbix_agentd.conf
+               fperms 0640 /etc/zabbix/zabbix_agentd.conf
+               fowners root:zabbix /etc/zabbix/zabbix_agentd.conf
+
+               newinitd "${FILESDIR}"/zabbix-agentd.init zabbix-agentd
+
+               dosbin src/zabbix_agent/zabbix_agentd
+               dobin \
+                       src/zabbix_sender/zabbix_sender \
+                       src/zabbix_get/zabbix_get
+
+               systemd_dounit "${FILESDIR}"/zabbix-agentd.service
+               systemd_newtmpfilesd "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
+       fi
+
+       fowners root:zabbix /etc/zabbix
+       fowners zabbix:zabbix \
+               /var/lib/zabbix \
+               /var/lib/zabbix/home \
+               /var/lib/zabbix/scripts \
+               /var/lib/zabbix/alertscripts \
+               /var/lib/zabbix/externalscripts \
+               /var/log/zabbix
+       fperms 0750 \
+               /etc/zabbix \
+               /var/lib/zabbix \
+               /var/lib/zabbix/home \
+               /var/lib/zabbix/scripts \
+               /var/lib/zabbix/alertscripts \
+               /var/lib/zabbix/externalscripts \
+               /var/log/zabbix
+
+       dodoc README INSTALL NEWS ChangeLog \
+               conf/zabbix_agentd.conf \
+               conf/zabbix_proxy.conf \
+               conf/zabbix_agentd/userparameter_examples.conf \
+               conf/zabbix_agentd/userparameter_mysql.conf \
+               conf/zabbix_server.conf
+
+       if use frontend; then
+               webapp_src_preinst
+               cp -R frontends/php/* "${D}/${MY_HTDOCSDIR}"
+               webapp_configfile \
+                       "${MY_HTDOCSDIR}"/include/db.inc.php \
+                       "${MY_HTDOCSDIR}"/include/config.inc.php
+               webapp_src_install
+       fi
+
+       if use java; then
+               dodir \
+                       /${ZABBIXJAVA_BASE} \
+                       /${ZABBIXJAVA_BASE}/bin \
+                       /${ZABBIXJAVA_BASE}/lib
+               keepdir /${ZABBIXJAVA_BASE}
+               exeinto /${ZABBIXJAVA_BASE}/bin
+               doexe src/zabbix_java/bin/zabbix-java-gateway-${MY_PV}.jar
+               exeinto /${ZABBIXJAVA_BASE}/lib
+               doexe \
+                       src/zabbix_java/lib/logback-classic-0.9.27.jar \
+                       src/zabbix_java/lib/logback-console.xml \
+                       src/zabbix_java/lib/logback-core-0.9.27.jar \
+                       src/zabbix_java/lib/logback.xml \
+                       src/zabbix_java/lib/android-json-4.3_r3.1.jar \
+                       src/zabbix_java/lib/slf4j-api-1.6.1.jar
+               newinitd "${FILESDIR}"/zabbix-jmx-proxy.init zabbix-jmx-proxy
+               newconfd "${FILESDIR}"/zabbix-jmx-proxy.conf zabbix-jmx-proxy
+       fi
+}
+
+pkg_postinst() {
+       if use server || use proxy ; then
+               elog
+               elog "You may need to configure your database for Zabbix"
+               elog "if you have not already done so."
+               elog
+
+               zabbix_homedir=$(egethome zabbix)
+               if [ -n "${zabbix_homedir}" ] && \
+                  [ "${zabbix_homedir}" != "/var/lib/zabbix/home" ]; then
+                       ewarn
+                       ewarn "The user 'zabbix' should have his homedir changed"
+                       ewarn "to /var/lib/zabbix/home if you want to use"
+                       ewarn "custom alert scripts."
+                       ewarn
+                       ewarn "A real homedir might be needed for configfiles"
+                       ewarn "for custom alert scripts."
+                       ewarn
+                       ewarn "To change the homedir use:"
+                       ewarn "  usermod -d /var/lib/zabbix/home zabbix"
+                       ewarn
+               fi
+       fi
+
+       if use server; then
+               elog
+               elog "For distributed monitoring you have to run:"
+               elog
+               elog "zabbix_server -n <nodeid>"
+               elog
+               elog "This will convert database data for use with Node ID"
+               elog "and also adds a local node."
+               elog
+       fi
+
+       elog "--"
+       elog
+       elog "You may need to add these lines to /etc/services:"
+       elog
+       elog "zabbix-agent     10050/tcp Zabbix Agent"
+       elog "zabbix-agent     10050/udp Zabbix Agent"
+       elog "zabbix-trapper   10051/tcp Zabbix Trapper"
+       elog "zabbix-trapper   10051/udp Zabbix Trapper"
+       elog
+
+       if use server || use proxy ; then
+               # check for fping
+               fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
+               case "${fping_perms}" in
+                       4[157][157][157])
+                               ;;
+                       *)
+                               ewarn
+                               ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
+                               ewarn "you have to make /usr/sbin/fping setuid root and executable"
+                               ewarn "by everyone. Run the following command to fix it:"
+                               ewarn
+                               ewarn "  chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
+                               ewarn
+                               ewarn "Please be aware that this might impose a security risk,"
+                               ewarn "depending on the code quality of fping."
+                               ewarn
+                               ;;
+               esac
+       fi
+}