app-misc/votrify: Bump to v4
authorMichał Górny <mgorny@gentoo.org>
Fri, 12 Jul 2019 17:55:27 +0000 (19:55 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 12 Jul 2019 17:59:13 +0000 (19:59 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-misc/votrify/Manifest
app-misc/votrify/votrify-4.ebuild [new file with mode: 0644]

index 5bb9256fc18c33d6e1808496aa2faa895ed2bf79..ec855c9761432de11ef9e0934fa8ded0d10e6616 100644 (file)
@@ -1,3 +1,4 @@
 DIST votrify-1.tar.gz 6936 BLAKE2B 7c9a5668842c5b1783e5c8b2341d42aa21257b96a82210c16e44bee8f71b690c7dba5acf48a39beff0189106db1fe141ef1ec30d68f25573a19a53c12618d346 SHA512 14fdb4ee185d96f416b47df7b29175cebc6e003aca7c1faf927b258f7dbe39b7ed69c4defb25900c6856b6e9abde3b03a69ca02152755d8532708b6cfb7f51a0
 DIST votrify-2.tar.gz 9095 BLAKE2B 801c9ad89f93349ce6ad0d9421e9a968a511d9699454c91cc713dd3a133c4f87666de3bc3905041999a5090eb5794d6ceed89aabc997e6950d2b5a4b4bb185cc SHA512 8c3795520d6ee5d34c8aa649a24309e30da8843bcddbfc8ff0b822eab5529a621d9fa475dc6714a6de0ed1d229d3a949870666967448a23036d28af5e7da00ab
 DIST votrify-3.tar.gz 9153 BLAKE2B fdff14dd7332bd6688cb2d04d87e7cf0888aa881cac6a98961cc544182869b190ac8591545c773e7a14293ff0fac7efd646be3cc7f8d059a8e45b709051eae69 SHA512 bde636cb238e114814f1246f49c9b5f363d7c9255da4cf2f5da6cb8da19f1b970e0027b630f21b0166c73de770e5bc931b811c3326ccc790db6d1d873731ef9e
+DIST votrify-4.tar.gz 9184 BLAKE2B 78149b3e53a830c405de70b0dff301eb4467489a59af8de76fade98eeeacc9ae78cc229db23eef26355579a9944917074419e2f38eb59eb0cae6d314985d0383 SHA512 1639fd6b6e96fb767088fb4b3be4d2d09cb0f6a12bdd745d610b6853ff2f585f8100523e92ee75d7800fe54cb42a5c716bbefe57d85395627e8c67d75e45aae1
diff --git a/app-misc/votrify/votrify-4.ebuild b/app-misc/votrify/votrify-4.ebuild
new file mode 100644 (file)
index 0000000..2786678
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit python-single-r1
+
+DESCRIPTION="Tool for community verification of Gentoo elections"
+HOMEPAGE="https://github.com/mgorny/votrify"
+SRC_URI="https://github.com/mgorny/votrify/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-misc/gentoo-elections"
+
+src_configure() {
+       # update default location for election scripts
+       sed -i -e "s^os.path.dirname(__file__)^'${EPREFIX}/usr/lib'^" \
+               votrify-make-confirmation || die
+
+       python_fix_shebang votrify-{make,verify}-*
+}
+
+make_wrappers() {
+       local election=${1}
+
+       newbin - "votrify-${election}-make" \
+               < <(sed -e "s^@ELECTION@^${election}^" \
+                       votrify-wrapper-make.bash.in || die)
+       newbin - "votrify-${election}-verify" \
+               < <(sed -e "s^@ELECTION@^${election}^" \
+                       votrify-wrapper-verify.bash.in || die)
+}
+
+src_install() {
+       dobin votrify-{make,verify}-*
+       make_wrappers council-201906
+       einstalldocs
+}
+
+pkg_postinst() {
+       elog "In order to interactively create confirmation for Council 2019 election:"
+       elog "  votrify-council-201906-make"
+       elog
+       elog "In order to verify the results for Council 2019 election:"
+       elog "  votrify-council-201906-verify"
+}