gnome-base/dconf: bump to 0.34.0
authorMart Raudsepp <leio@gentoo.org>
Sat, 14 Mar 2020 22:13:27 +0000 (00:13 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sat, 14 Mar 2020 22:32:34 +0000 (00:32 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-base/dconf/Manifest
gnome-base/dconf/dconf-0.34.0.ebuild [new file with mode: 0644]

index c5a30c9a42fbe3cdee170abca31bdfb8d60334f7..c447564b0220bd2fa5b9be5ca4b0f01408c949c6 100644 (file)
@@ -1 +1,2 @@
 DIST dconf-0.32.0.tar.xz 111700 BLAKE2B 51ac54deafc44a56aa6af1bdc8a89e1002772969881870b196a12f85d5b1a090a334b3088b051e07e085b7fe736e2e51479c17ffcc38a18e682b8238d51671ee SHA512 09ae65ad365947aed24228b94978b290060264e55b443d18a743e943627703c92e16e3a5ca8a0aaf3549f7a1d5aad77bdc285d4c8519db705d3104ec22b111a0
+DIST dconf-0.34.0.tar.xz 112876 BLAKE2B 6890cd82a3ba81eac8c72dda93ebf1b82f3002b735bf2e059ba07a2f0f3817978a9e4f5dd37a9efab728fc2a4e20c34c519f9eeb3915d705ff8a3c4a65f9ab41 SHA512 8b28373f31fe36ba3f21f56fca84563681c3648ff595709880cd9ac49fc6b130ac375fb89fd585f1dd62b5a2f728127292ea57d18feca1147b709a93e8c4c743
diff --git a/gnome-base/dconf/dconf-0.34.0.ebuild b/gnome-base/dconf/dconf-0.34.0.ebuild
new file mode 100644 (file)
index 0000000..6d67755
--- /dev/null
@@ -0,0 +1,83 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 gnome.org gnome2-utils meson virtualx xdg
+
+DESCRIPTION="Simple low-level configuration system"
+HOMEPAGE="https://wiki.gnome.org/Projects/dconf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-linux"
+IUSE="gtk-doc"
+RESTRICT="!test? ( test )" # IUSE=test comes from virtualx.eclass
+
+RDEPEND="
+       >=dev-libs/glib-2.44.0:2
+       sys-apps/dbus
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       app-text/docbook-xml-dtd:4.2
+       app-text/docbook-xsl-stylesheets
+       dev-libs/libxslt
+       dev-util/gdbus-codegen
+       gtk-doc? ( >=dev-util/gtk-doc-1.15 )
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+PATCHES=(
+       "${FILESDIR}"/0.30.1-bash-completion-dir.patch
+       "${FILESDIR}"/0.32.0-drop-vapigen-dep.patch # .vapi/.deps are pregenerated, just install them without a vala dep
+       "${FILESDIR}"/0.32.0-meson-0.52-compat.patch # https://gitlab.gnome.org/GNOME/dconf/issues/59
+)
+
+src_configure() {
+       local emesonargs=(
+               -Dbash_completion_dir="$(get_bashcompdir)"
+               -Dman=true
+               $(meson_use gtk-doc gtk_doc)
+               -Dvapi=true
+       )
+       meson_src_configure
+}
+
+src_install() {
+       meson_src_install
+
+       # GSettings backend may be one of: memory, gconf, dconf
+       # Only dconf is really considered functional by upstream
+       # must have it enabled over gconf if both are installed
+       # This snippet can't be removed until gconf package is
+       # ensured to not install a /etc/env.d/50gconf and then
+       # still consider the CONFIG_PROTECT_MASK bit.
+       echo 'CONFIG_PROTECT_MASK="/etc/dconf"' >> 51dconf
+       echo 'GSETTINGS_BACKEND="dconf"' >> 51dconf
+       doenvd 51dconf
+}
+
+src_test() {
+       virtx meson_src_test
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_giomodule_cache_update
+
+       # Kill existing dconf-service processes as recommended by upstream due to
+       # possible changes in the dconf private dbus API.
+       # dconf-service will be dbus-activated on next use.
+       pids=$(pgrep -x dconf-service)
+       if [[ $? == 0 ]]; then
+               ebegin "Stopping dconf-service; it will automatically restart on demand"
+               kill ${pids}
+               eend $?
+       fi
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_giomodule_cache_update
+}