media-sound/cvoicecontrol: bump EAPI
authorAaron Bauman <bman@gentoo.org>
Mon, 28 May 2018 00:01:15 +0000 (20:01 -0400)
committerAaron Bauman <bman@gentoo.org>
Mon, 28 May 2018 23:01:55 +0000 (19:01 -0400)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha-r1.ebuild

index eb49302b044ec52985a91ce85459f9ee08004df3..1ae69c38d01cb8cf116d7420f754a880c909e159 100644 (file)
@@ -1,8 +1,7 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=2
-inherit eutils
+EAPI=7
 
 MY_P=${P/_/}
 
@@ -17,15 +16,16 @@ IUSE=""
 
 S=${WORKDIR}/${MY_P}
 
+PATCHES=( "${FILESDIR}/${P}-gentoo-2.patch" )
+
 src_prepare() {
-       epatch "${FILESDIR}"/${P}-gentoo-2.patch
+       eapply_user
        sed -i -e "s/install-data-am: install-data-local/install-data-am:/" Makefile.in
        # Handle documentation with dohtml instead.
        sed -i -e "s:SUBDIRS = docs:#SUBDIRS = docs:" cvoicecontrol/Makefile.in
 }
 
 src_install () {
-       emake DESTDIR="${D}" install || die "emake install failed"
-       dodoc AUTHORS BUGS ChangeLog FAQ README
-       dohtml cvoicecontrol/docs/en/*.html
+       HTML_DOCS=( cvoicecontrol/docs/en/*.html )
+       default
 }