games-emulation/mupen64plus-core: rename USE=gles2 to USE=gles2-only
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>
Sat, 23 Nov 2019 09:51:05 +0000 (10:51 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 3 Apr 2020 14:56:43 +0000 (16:56 +0200)
Closes: https://github.com/gentoo/gentoo/pull/15133
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
games-emulation/mupen64plus-core/metadata.xml
games-emulation/mupen64plus-core/mupen64plus-core-2.5.9-r1.ebuild [moved from games-emulation/mupen64plus-core/mupen64plus-core-2.5.9.ebuild with 92% similarity]

index 4e8fd61a24bac50ccb1be9bfdcbdbed53d1f6bf9..d4cc98359e4b54cae31c6a8d79bfe80b0ccccdc0 100644 (file)
@@ -7,7 +7,6 @@
        </maintainer>
        <use>
                <flag name="debugger">Build the debugger</flag>
-               <flag name="gles2">Use GLES2 instead of OpenGL</flag>
                <flag name="new-dynarec">Enable new experimental dynamic recompiler implementation (only for x86 and arm)</flag>
                <flag name="opencv">Support video capture via <pkg>media-libs/opencv</pkg></flag>
                <flag name="osd">Overlay emulator messages using on-screen-display</flag>
similarity index 92%
rename from games-emulation/mupen64plus-core/mupen64plus-core-2.5.9.ebuild
rename to games-emulation/mupen64plus-core/mupen64plus-core-2.5.9-r1.ebuild
index 5bf2f73d58f86dad8026e67187027defa3a5ba58..57dc6a6f2305f9e9bf8ccf4a37fd9f0255505d1a 100644 (file)
@@ -13,12 +13,12 @@ SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.ta
 LICENSE="GPL-2+"
 SLOT="0/2-sdl2"
 KEYWORDS="~amd64 ~x86"
-IUSE="debugger gles2 lirc new-dynarec opencv +osd cpu_flags_x86_sse"
+IUSE="debugger gles2-only lirc new-dynarec opencv +osd cpu_flags_x86_sse"
 
 RDEPEND="media-libs/libpng:0=
        media-libs/libsdl2:0=[joystick,opengl,video]
        sys-libs/zlib:0=[minizip]
-       gles2? ( media-libs/libsdl2:0[gles] )
+       gles2-only? ( media-libs/libsdl2:0[gles] )
        lirc? ( app-misc/lirc:0 )
        opencv? ( media-libs/opencv:= )
        osd? (
@@ -30,7 +30,7 @@ RDEPEND="media-libs/libpng:0=
 DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
-REQUIRED_USE="gles2? ( !osd )"
+REQUIRED_USE="gles2-only? ( !osd )"
 S=${WORKDIR}/${MY_P}
 
 PATCHES=( "${FILESDIR}"/${PN}-2.5.9-fix-gcc10-fno-common.patch )
@@ -82,7 +82,7 @@ src_compile() {
                OPENCV=$(usex opencv 1 0)
                DEBUGGER=$(usex debugger 1 0)
                NEW_DYNAREC=$(usex new-dynarec 1 0)
-               USE_GLES=$(usex gles2 1 0)
+               USE_GLES=$(usex gles2-only 1 0)
        )
 
        use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )