sys-kernel/linux-firmware: fix src_unpack
authorThomas Deutschmann <whissi@gentoo.org>
Wed, 18 Mar 2020 19:45:56 +0000 (20:45 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Wed, 18 Mar 2020 19:46:05 +0000 (20:46 +0100)
Allow usage of upstream tags.

Bug: https://bugs.gentoo.org/713280
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
sys-kernel/linux-firmware/linux-firmware-20200316.ebuild

index e42b02d3761d155fae931fdf4fef903fba54e05f..3e7ea3c45bb0fab460955263ecf142a4ea4c71dd 100644 (file)
@@ -84,7 +84,9 @@ src_unpack() {
        else
                default
                # rename directory from git snapshot tarball
-               mv ${PN}-*/ ${P} || die
+               if [[ ${#GIT_COMMIT} > 8 ]]; then
+                       mv ${PN}-*/ ${P} || die
+               fi
        fi
 }