app-admin/mcollective: 2.12.3 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 22 Aug 2018 05:15:36 +0000 (00:15 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 22 Aug 2018 05:17:16 +0000 (00:17 -0500)
Package-Manager: Portage-2.3.48, Repoman-2.3.10

app-admin/mcollective/Manifest
app-admin/mcollective/mcollective-2.12.3.ebuild [new file with mode: 0644]

index c25fd65bad62ae1fdf40e4d564a23be4595a4d62..576d8d8a6ea04eb62e263b57b3b6f2bce11bfe6f 100644 (file)
@@ -1,2 +1,3 @@
 DIST mcollective-2.12.1.tar.gz 1517946 BLAKE2B 785acc53a4854f47caebe1d6a5f9cc850c3c33fd21e1b6e57d0d9761b2a7a3bbab2f2df398aa5344d90bc11397a545c8663d60ff3b2f6ff835fdc619d874928e SHA512 2398fb0202d8d5669a6efa81d96a87ee7e9221c1bc1b2e5be1917f2fec2527879b34be8df8c3052acf0ed58074b2da185f0837889d9300bde190bc95e8237d9a
 DIST mcollective-2.12.2.tar.gz 1517725 BLAKE2B e5f2b94843b95fa0749ed7e3e1ae52aeb485bf6644b64d971efd7d7a0e7bc806de0d2b00997c7e36d004fd78c479b9cf19b927e717ad0f3e4c13e820e5481637 SHA512 83be835499adf836797a67adda9be6d1bbf32524560ae51533875a1e2507599c7a0a1d2a76513669b919cf1eeceabdf13162eedb8972c74ecdeba5427b1701e4
+DIST mcollective-2.12.3.tar.gz 1516461 BLAKE2B f8fa65ffadb98ae3511416aaf8b0875486b75f20e4da4007ad70820f453a6ecd81b57d7aa30ae38b014b984330f6c4d525002a54edb2c00d629b6fd4b2250049 SHA512 55798d4579a6be8a7790b046f8b4e72607935c83ec874b6147258d827e0bf279f08dfa121d7cc4a8ed922986aa6bad9ebd62b7e3cbc1e7ef526cf58edce1bcdc
diff --git a/app-admin/mcollective/mcollective-2.12.3.ebuild b/app-admin/mcollective/mcollective-2.12.3.ebuild
new file mode 100644 (file)
index 0000000..6682ac7
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="https://docs.puppet.com/mcollective/"
+SRC_URI="https://github.com/puppetlabs/marionette-collective/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/all/marionette-collective-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND=">=dev-ruby/stomp-1.4.4"
+
+src_compile() {
+       einfo "nothing to compile"
+}
+
+each_ruby_install() {
+       cd "marionette-collective-${PV}"
+       doruby -r lib/*
+       insinto /usr/share/mcollective
+       use client && dosbin bin/mco
+       dosbin bin/mcollectived
+       if use doc ; then
+               dohtml -r doc/*
+               insinto /usr/share/doc/${P}/ext
+               doins -r ext/*
+       fi
+       newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+       insinto /etc/mcollective
+       cd etc
+       for cfg in *.dist ; do
+               newins "${cfg}" "${cfg%%.dist}"
+               sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+                       "${D}"/etc/mcollective/${cfg%%.dist} || die "sed failed"
+       done
+       insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+       einfo "Mcollective requires a stomp server installed and functioning before"
+       einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+       einfo "any other stomp compatible server should work."
+       einfo
+       einfo "It is recommended you read the \'getting started\' guide [2] if this"
+       einfo "is a new installation"
+       einfo
+       einfo "[1] https://activemq.apache.org/"
+       einfo "[2] https://code.google.com/p/mcollective/wiki/GettingStarted"
+}