dev-db/mariadb: Remove security vulnerable version wrt bug 555480
authorBrian Evans <grknight@gentoo.org>
Thu, 24 Sep 2015 12:33:33 +0000 (08:33 -0400)
committerBrian Evans <grknight@gentoo.org>
Thu, 24 Sep 2015 12:40:06 +0000 (08:40 -0400)
Package-Manager: portage-2.2.20.1

dev-db/mariadb/Manifest
dev-db/mariadb/mariadb-10.0.19.ebuild [deleted file]

index 58983d0f36381e42a814239fb80519fa4f7c8d0c..f9d71d8fb627d9a5cedfbdd15240b30bf230dd62 100644 (file)
@@ -1,4 +1,3 @@
-DIST mariadb-10.0.19.tar.gz 56224123 SHA256 2fbf5e5d7d8094691601ece8ae60b941478d73c98a58a960aeebfa021091a132 SHA512 bfb2a3e9225b3dd7481c0240143346f38be80c426887e05ec2b8eeab251991e2a5f74788f421322342a0fa8f85294cf4c7f5d4fd10d7bc6b9da720f6168003f3 WHIRLPOOL d08c53228c40df18793316dd0eddb160ce5b67a853f16c4ddcdcedb049833b35b9ae9d0763e1fcc1e447e3528ae9a7ab2e6587dd2e2c0a225224f28a951dc3dd
 DIST mariadb-10.0.21.tar.gz 56216903 SHA256 4b9a32e15ceadefdb1057a02eb3e0addf702b75aef631a3c9194b832ecfa3545 SHA512 75aa4b019f3432a61483bb325a0f088ea92d6fede44d7a300c15659411c8927fa2a0586182226315b6d6796641ca1d8746f7fd49e21fe21505adec1fc38ae32f WHIRLPOOL b086fb34363b2426f5e91c14916b747787feadf37c609f4aea1f08bd235e9e97df17f5bfa0eb9e65e93fbed3df5eb6c021287c4eb987a3362ea87cf96eaf268e
 DIST mariadb-10.1.7.tar.gz 53812743 SHA256 5bd3b80cf0f312751271a3446c12579c7081f93406e59a0cdfda8e133423c88f SHA512 4a496ba22ccc839d412dd4858cb66464b499693c4ff89ea773a967bccc7d53a52622f3d494d6f889c5325b079d83ba17b25abae2bc9fc22b76c601fc51542f5a WHIRLPOOL 2366c46a7c6d83dd9fe7cac9affcb00387a574912ad9350c11279d31fd384e5fcc18a5d297765086b2f9208e5b899a7707cfb199d047309b89725d0e9582cd9d
 DIST mariadb-5.5.45.tar.gz 45686618 SHA256 4dc3aff6941ef1068412002915d795bcf67db0eaa38a5c6f3af57474c4226fb0 SHA512 57501670605cfcdd231ef57d2db7ac9bf460856e63c0660d050ad11aa0392d3d6ce6730ae119dca5d00847c9170990f375c8499593bf0d02c1995395191236ba WHIRLPOOL e5ef471c097c2b8921596b88f26df6914e031daafdcd878d79a16c20be6ba8c97fb79069e48d7d1b9aa405ced063f66feac1c52503907e06ee4b577def2c57fa
diff --git a/dev-db/mariadb/mariadb-10.0.19.ebuild b/dev-db/mariadb/mariadb-10.0.19.ebuild
deleted file mode 100644 (file)
index 6a68b6e..0000000
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-MY_EXTRAS_VER="20141215-0144Z"
-
-inherit toolchain-funcs mysql-multilib
-# only to make repoman happy. it is really set in the eclass
-IUSE="$IUSE"
-
-# REMEMBER: also update eclass/mysql*.eclass before committing!
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-
-# When MY_EXTRAS is bumped, the index should be revised to exclude these.
-EPATCH_EXCLUDE=''
-
-DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )"
-RDEPEND="${RDEPEND}"
-
-# Official test instructions:
-# USE='embedded extraengine perl ssl static-libs community' \
-# FEATURES='test userpriv -usersandbox' \
-# ebuild mariadb-X.X.XX.ebuild \
-# digest clean package
-multilib_src_test() {
-
-       if ! multilib_is_native_abi ; then
-               einfo "Server tests not available on non-native abi".
-               return 0;
-       fi
-
-       local TESTDIR="${BUILD_DIR}/mysql-test"
-       local retstatus_unit
-       local retstatus_tests
-
-       # Bug #213475 - MySQL _will_ object strenously if your machine is named
-       # localhost. Also causes weird failures.
-       [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
-
-       if ! use "minimal" ; then
-
-               if [[ $UID -eq 0 ]]; then
-                       die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
-               fi
-               has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
-               einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
-               addpredict /this-dir-does-not-exist/t9.MYI
-
-               # Run CTest (test-units)
-               cmake-utils_src_test
-               retstatus_unit=$?
-               [[ $retstatus_unit -eq 0 ]] || eerror "test-unit failed"
-
-               # Ensure that parallel runs don't die
-               export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
-               # Enable parallel testing, auto will try to detect number of cores
-               # You may set this by hand.
-               # The default maximum is 8 unless MTR_MAX_PARALLEL is increased
-               export MTR_PARALLEL="${MTR_PARALLEL:-auto}"
-
-               # create directories because mysqladmin might right out of order
-               mkdir -p "${T}"/var-tests{,/log}
-
-               # These are failing in MariaDB 10.0 for now and are believed to be
-               # false positives:
-               #
-               # main.information_schema, binlog.binlog_statement_insert_delayed,
-               # main.mysqld--help, funcs_1.is_triggers, funcs_1.is_tables_mysql,
-               # funcs_1.is_columns_mysql main.bootstrap
-               # fails due to USE=-latin1 / utf8 default
-               #
-               # main.mysql_client_test, main.mysql_client_test_nonblock
-               # main.mysql_client_test_comp:
-               # segfaults at random under Portage only, suspect resource limits.
-               #
-
-               for t in main.mysql_client_test main.mysql_client_test_nonblock \
-                       main.mysql_client_test_comp \
-                       binlog.binlog_statement_insert_delayed main.information_schema \
-                       main.mysqld--help main.bootstrap \
-                       funcs_1.is_triggers funcs_1.is_tables_mysql funcs_1.is_columns_mysql ; do
-                               mysql-multilib_disable_test  "$t" "False positives in Gentoo"
-               done
-
-               # Run mysql tests
-               pushd "${TESTDIR}"
-
-               # run mysql-test tests
-               perl mysql-test-run.pl --force --vardir="${T}/var-tests"
-
-               retstatus_tests=$?
-               [[ $retstatus_tests -eq 0 ]] || eerror "tests failed"
-               has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
-               popd
-
-               # Cleanup is important for these testcases.
-               pkill -9 -f "${S}/ndb" 2>/dev/null
-               pkill -9 -f "${S}/sql" 2>/dev/null
-
-               failures=""
-               [[ $retstatus_unit -eq 0 ]] || failures="${failures} test-unit"
-               [[ $retstatus_tests -eq 0 ]] || failures="${failures} tests"
-               has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
-               [[ -z "$failures" ]] || die "Test failures: $failures"
-               einfo "Tests successfully completed"
-
-       else
-
-               einfo "Skipping server tests due to minimal build."
-       fi
-}