dev-python/uritemplate: 3.0.1 bump
authorWilliam Hubbs <william.hubbs@sony.com>
Wed, 11 Mar 2020 21:45:52 +0000 (16:45 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Wed, 11 Mar 2020 21:56:15 +0000 (16:56 -0500)
Signed-off-by: William Hubbs <williamh@gentoo.org>
dev-python/uritemplate/Manifest
dev-python/uritemplate/uritemplate-3.0.1.ebuild [new file with mode: 0644]

index c54af33489fbc91d38151b512787b62fb4776ea4..976fbb365f35bfd6f3d8275dab4e46a6fc2d4869 100644 (file)
@@ -1,2 +1,3 @@
 DIST uritemplate-0.6.tar.gz 3508 BLAKE2B 41abd9a347a6ab0fae668a63c185d64e857cb88431a3b8ecaa673076a1fb700869c1679313ed772c2aade5952cbad7f0ce898f4be4ea280fe8d867cf1c280911 SHA512 19e9d2f7cb6275c1a3bc6e287d9d3bdbed4391541f29765130a8e33825321e33fe3220adc349794d179354bcb9d77571ae20ba7836034962f3713994c7cdbfbd
 DIST uritemplate-3.0.0.tar.gz 30038 BLAKE2B eac4deaa980a9a4618a245bfdc8b3df2180a4285b9197488e7556e3cbce88c4a52ee8bdfecc5f500d80d14a59f8ff0e1ecbcb3aedff422fa9853cb2d40e25df4 SHA512 9988ae6db1d0234a2dfb393ab0205dd7902c814b8a85e06a666b8fec44cacec90fc8852b64da068242cb57cbb2ed63478567224fcb6751df82605d1f0881ad6e
+DIST uritemplate-3.0.1.tar.gz 32806 BLAKE2B 71fb7ef9fbdd61f3a3f67c5615cfb65ab261b5f9ce1c5a534e155a9723990599bf50e9ee0934d870161f7f26fc3d0fbcc07fefa558fc55bca29e96259bba767a SHA512 260da5901d28ca2354d972e00ed468c9bcf2901f948cb7759ff3e9d3a7b67da90ba754e555d6695c5095801b106ffd422459f0860b901a75e01575e159eb8f48
diff --git a/dev-python/uritemplate/uritemplate-3.0.1.ebuild b/dev-python/uritemplate/uritemplate-3.0.1.ebuild
new file mode 100644 (file)
index 0000000..a4ea032
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of RFC6570, URI Template"
+HOMEPAGE="https://pypi.org/project/uritemplate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="amd64 arm ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+       dev-python/simplejson[${PYTHON_USEDEP}]
+       !<=dev-python/google-api-python-client-1.3"
+DEPEND="${RDEPEND}"