sys-devel/gcc: rebase live ebuild against 9.3.0-1 patchset
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 14 Mar 2020 10:16:11 +0000 (10:16 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 14 Mar 2020 10:16:11 +0000 (10:16 +0000)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-devel/gcc/gcc-10.0.1_pre9999.ebuild

index 327bd78912feb92ce0f5c910d2b070978e292433..e2563a1946a979090a75310ad417bf0b05dc09b3 100644 (file)
@@ -3,8 +3,8 @@
 
 EAPI="7"
 
-PATCH_GCC_VER="9.2.0" # reuse subset of patches for latest for live ebuilds gcc
-PATCH_VER="4"
+PATCH_GCC_VER="9.3.0" # reuse subset of patches for latest for live ebuilds gcc
+PATCH_VER="1"
 
 inherit toolchain
 
@@ -27,20 +27,12 @@ src_prepare() {
        local p ignore_patches=(
                04_all_default-ssp-fix.patch # needs a port
                11_all_extra-options.patch # needs a port
-               15_all_disable-systemtap-switch.patch # needs a port
 
                12_all_pr55930-dependency-tracking.patch # upstreamed
                25_all_ia64-bootstrap.patch # upstreamed
-               27_all_sparc-PIC-constant-PR91472.patch # upstreamed
-               28_all_sparc-fpu-subregs-91269.patch # upstreamed
-               29_all_mips_split_move-SEGV.patch # upstreamed
-               30_all_arm64-march-native.patch # upstreamed
-               31_all_openmp-for-SEGV.patch # upstreamed
-               32_all_sparc-PIC-constant-part2.patch # upstreamed
-               33_all_extend-lifetime.patch # upstreamed
        )
        for p in "${ignore_patches[@]}"; do
-               rm "${WORKDIR}"/patch/"${p}" || die "failed to delete '${p}'"
+               mv -v "${WORKDIR}"/patch/"${p}" "${WORKDIR}"/patch/"${p}"_disabled || die "failed to disable '${p}'"
        done
 
        toolchain_src_prepare