dev-python/pytools: bump to 2020.1
authort0b3 <thomas.bettler@gmail.com>
Sat, 21 Mar 2020 16:49:56 +0000 (17:49 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 30 Mar 2020 17:43:56 +0000 (19:43 +0200)
Closes: https://bugs.gentoo.org/712672
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: t0b3 <thomas.bettler@gmail.com>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytools/Manifest
dev-python/pytools/pytools-2020.1.ebuild [new file with mode: 0644]

index e01a81258ea8de0ad3dc88caeb54b666e1e3e10c..b44ddf7b774a01522c8344d5d7a93cf6c50d72c2 100644 (file)
@@ -1 +1,2 @@
 DIST pytools-2017.4.tar.gz 51339 BLAKE2B 725518ea3aab7fb158134f9539fe1f42603beebb547260e3556466d89b084bcd0adc367bbad63a461553c88eb5c50e2c2f510a02bfb99b9e3affab29eaddf148 SHA512 4f588b725bc478303d539851110ad627baa2768d5d013434ca20e36fa315a842d0f7c3adebd5ae948f642fc5b9ad4940fbe1ee6afeaf0f16c4bc937210e9fa19
+DIST pytools-2020.1.tar.gz 60662 BLAKE2B fcab8af5e10a483f9fdbb835bbc18fc98ebf3da80da9c8e98ff5131eb4a9e780562827966ba15f64df17ee46c48ef2498caf292e29b6b838ebfc5a49a1dccbae SHA512 b8b6513677f84fe97dfee9b96449ce6f2bad5d1dbd51a4f36b080136efd3b1d97850f02ec52e8e70c317104f99ad383dd9d2b260f0c151eb11851b03efcefe58
diff --git a/dev-python/pytools/pytools-2020.1.ebuild b/dev-python/pytools/pytools-2020.1.ebuild
new file mode 100644 (file)
index 0000000..c5f9cf4
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of tools missing from the Python standard library"
+HOMEPAGE="https://mathema.tician.de/software/pytools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+       >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+       >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.8.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+       >=dev-python/setuptools-0.7.2[${PYTHON_USEDEP}]
+       test? ( ${RDEPEND} )
+"
+
+distutils_enable_tests pytest