sys-libs/libcxxabi: Use BDEPEND semi-properly
authorMichał Górny <mgorny@gentoo.org>
Tue, 17 Sep 2019 21:00:24 +0000 (23:00 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 17 Sep 2019 21:00:55 +0000 (23:00 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-libs/libcxxabi/libcxxabi-10.0.0.9999.ebuild
sys-libs/libcxxabi/libcxxabi-9.0.0.9999.ebuild

index 316f3e78ca835d9938a9572866650234b00abfa7..edc18f6fea904939c92b9711055fc919c2bacf0e 100644 (file)
@@ -31,7 +31,8 @@ RDEPEND="
        )"
 # llvm-6 for new lit options
 DEPEND="${RDEPEND}
-       >=sys-devel/llvm-6
+       >=sys-devel/llvm-6"
+BDEPEND="
        test? ( >=sys-devel/clang-3.9.0
                $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
 
index 163710a82a71ca977ce37f55f314274e3e56d33d..70fcb998c05d399e02db715815635b0668294e4a 100644 (file)
@@ -32,7 +32,8 @@ RDEPEND="
        )"
 # llvm-6 for new lit options
 DEPEND="${RDEPEND}
-       >=sys-devel/llvm-6
+       >=sys-devel/llvm-6"
+BDEPEND="
        test? ( >=sys-devel/clang-3.9.0
                $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"