net-libs/telepathy-qt: python3_8 support
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Apr 2020 13:20:39 +0000 (15:20 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Apr 2020 14:17:03 +0000 (16:17 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild

index 12ca100f7091b9cac85264bb95591b1b0b3c6ddf..021e7a634ee6f71fb9e739128d9820b597a8e0e4 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 inherit python-any-r1 cmake virtualx
 
 DESCRIPTION="Qt bindings for the Telepathy D-Bus protocol"
@@ -17,6 +17,8 @@ IUSE="debug farstream test"
 
 REQUIRED_USE="test? ( farstream )"
 
+RESTRICT="!test? ( test )"
+
 RDEPEND="
        dev-qt/qtcore:5
        dev-qt/qtdbus:5
@@ -43,7 +45,6 @@ BDEPEND="${PYTHON_DEPS}
                ')
        )
 "
-RESTRICT="!test? ( test )"
 
 python_check_deps() {
        use test || return 0