net-misc/bridge-utils: fix hardcoded ar
authorRobin H. Johnson <robbat2@gentoo.org>
Tue, 21 Apr 2020 17:25:06 +0000 (10:25 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Tue, 21 Apr 2020 17:25:06 +0000 (10:25 -0700)
Closes: https://bugs.gentoo.org/show_bug.cgi?id=717700
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
net-misc/bridge-utils/bridge-utils-1.5.ebuild
net-misc/bridge-utils/bridge-utils-1.6.ebuild

index db1eb2d66e3c47fe679acc35da827666b72b2b05..d48b3a0242bc199ec07ef082aebb87bcbda93ce6 100644 (file)
@@ -41,6 +41,10 @@ src_configure() {
                --with-linux-headers="$(get_headers)"
 }
 
+src_compile() {
+       emake AR=$(tc-getAR)
+}
+
 src_install() {
        emake install DESTDIR="${D}"
        dodoc AUTHORS ChangeLog README THANKS TODO \
index 1e911905bc215c58275866b7ddf2a3b4885aedca..a371017e1588d3128f4358b5016dd71428d23810 100644 (file)
@@ -44,6 +44,10 @@ src_configure() {
        econf "${myeconfargs[@]}"
 }
 
+src_compile() {
+       emake AR=$(tc-getAR)
+}
+
 src_install() {
        emake install DESTDIR="${D}"
        dodoc AUTHORS ChangeLog README THANKS TODO \