app-editors/gedit: Port to python-single-r1
authorDavid Seifert <soap@gentoo.org>
Thu, 16 Mar 2017 18:54:22 +0000 (19:54 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 16 Mar 2017 19:10:52 +0000 (20:10 +0100)
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Closes: https://github.com/gentoo/gentoo/pull/4175

app-editors/gedit/gedit-3.20.2.ebuild
app-editors/gedit/gedit-3.22.0.ebuild

index e19b56b49a1dcd6ff3c724b91f6438ae0418155f..bc8a01f8cd9d6cdb5581a3217edb1532347e52bc 100644 (file)
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{4,5} )
 VALA_MIN_API_VERSION="0.26"
 VALA_USE_DEPEND="vapigen"
 
-inherit eutils gnome2 multilib python-r1 vala virtualx
+inherit eutils gnome2 multilib python-single-r1 vala virtualx
 
 DESCRIPTION="A text editor for the GNOME desktop"
 HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
@@ -16,12 +16,7 @@ LICENSE="GPL-2+ CC-BY-SA-3.0"
 SLOT="0"
 
 IUSE="+introspection +python spell vala"
-# python-single-r1 would request disabling PYTHON_TARGETS on libpeas
-# we need to fix that
-REQUIRED_USE="
-       python? ( introspection )
-       python? ( ^^ ( $(python_gen_useflags '*') ) )
-"
+REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} )"
 
 KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
 
@@ -65,7 +60,7 @@ DEPEND="${COMMON_DEPEND}
 # yelp-tools, gnome-common needed to eautoreconf
 
 pkg_setup() {
-       use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+       use python && [[ ${MERGE_TYPE} != binary ]] && python-single-r1_pkg_setup
 }
 
 src_prepare() {
index e77e4f2624fa50ecab75215381f91382694217b6..207bc1e9f00b9521676c9314d0cef96b3112e901 100644 (file)
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{4,5} )
 VALA_MIN_API_VERSION="0.26"
 VALA_USE_DEPEND="vapigen"
 
-inherit eutils gnome2 multilib python-r1 vala virtualx
+inherit eutils gnome2 multilib python-single-r1 vala virtualx
 
 DESCRIPTION="A text editor for the GNOME desktop"
 HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
@@ -16,12 +16,7 @@ LICENSE="GPL-2+ CC-BY-SA-3.0"
 SLOT="0"
 
 IUSE="+introspection +python spell vala"
-# python-single-r1 would request disabling PYTHON_TARGETS on libpeas
-# we need to fix that
-REQUIRED_USE="
-       python? ( introspection )
-       python? ( ^^ ( $(python_gen_useflags '*') ) )
-"
+REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} )"
 
 KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
 
@@ -61,7 +56,7 @@ DEPEND="${COMMON_DEPEND}
 # yelp-tools, gnome-common needed to eautoreconf
 
 pkg_setup() {
-       use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+       use python && [[ ${MERGE_TYPE} != binary ]] && python-single-r1_pkg_setup
 }
 
 src_prepare() {