x11-misc/gigolo: Bump to 0.5.1
authorMichał Górny <mgorny@gentoo.org>
Sun, 15 Mar 2020 04:43:55 +0000 (05:43 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 15 Mar 2020 17:01:03 +0000 (18:01 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
x11-misc/gigolo/Manifest
x11-misc/gigolo/gigolo-0.5.1.ebuild [new file with mode: 0644]

index 0b4e966af627c6cce0740b5215287d7aa2704348..0e0b2b4a1ed463193b3c60fb11dafdae46c1b77d 100644 (file)
@@ -1 +1,2 @@
 DIST gigolo-0.5.0.tar.bz2 246473 BLAKE2B 23459a57467fefcc13c61483397837da51294fe7945619e0580b034dac14da192acb349b2334669f35ec43e1e421664b1765fb1e51164d7dca76769f27cef075 SHA512 5f33f24169c2a8e3a450926668e4611aa0a9c669edb6ef6e53bccd77228ac78b40c4916eb4a20afcd9d5d7e32373e8f13fd1cf43366e65166a9ef09366c9703b
+DIST gigolo-0.5.1.tar.bz2 246788 BLAKE2B 524307017a5d07107ded81af71e7758c60538abec2e75e5ab4e4f3c57ff82ea557e6f7b009ecbd6d7cd42fdf8fe8a8872ff973fc5051753dcc70341fee953bc5 SHA512 a21e2e808db4a16b7bcd9019e936cac57f67a76d6a9a9e34ed3eb7faa4cd5997bc561d1e9817d8e77efbf8ab0a954bc7f25719941672f604cc415caf0cb61e09
diff --git a/x11-misc/gigolo/gigolo-0.5.1.ebuild b/x11-misc/gigolo/gigolo-0.5.1.ebuild
new file mode 100644 (file)
index 0000000..227fa91
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="a frontend to easily manage connections to remote filesystems using GIO/GVfs"
+HOMEPAGE="https://www.uvena.de/gigolo/ https://goodies.xfce.org/projects/applications/gigolo"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.16
+       >=x11-libs/gtk+-3.14:3"
+DEPEND="${RDEPEND}
+       dev-util/intltool
+       virtual/pkgconfig"
+
+src_prepare() {
+       rm COPYING || die
+       default
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+}