dev-python/neovim-python-client: update DEPEND/RDEPEND.
authorPatrice Clement <monsieurp@gentoo.org>
Wed, 27 Mar 2019 23:52:28 +0000 (00:52 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Wed, 27 Mar 2019 23:56:04 +0000 (00:56 +0100)
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-python/neovim-python-client/neovim-python-client-0.3.1-r1.ebuild [new file with mode: 0644]
dev-python/neovim-python-client/neovim-python-client-0.3.1.ebuild
dev-python/neovim-python-client/neovim-python-client-0.3.2-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/neovim-python-client/neovim-python-client-0.3.1-r1.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.3.1-r1.ebuild
new file mode 100644 (file)
index 0000000..5e5ba98
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for Neovim"
+HOMEPAGE="https://github.com/neovim/pynvim"
+SRC_URI="https://github.com/neovim/pynvim/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+       dev-python/msgpack[${PYTHON_USEDEP}]
+       virtual/python-greenlet[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)"
+
+RDEPEND="
+       ${DEPEND}
+       >=app-editors/neovim-0.2.1"
+
+S="${WORKDIR}/pynvim-${PV}"
+
+python_prepare_all() {
+       # allow useage of renamed msgpack
+       sed -i '/^msgpack/d' setup.py || die
+       distutils-r1_python_prepare_all
+}
index 751a436d4fda14bd11ca31532ec8b31b1939db7f..9c534e297e694e36ec5724082419afdfc479287a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -21,7 +21,7 @@ DEPEND="
 
 RDEPEND="
        ${DEPEND}
-       >=app-editors/neovim-0.2.1"
+       app-editors/neovim"
 
 S="${WORKDIR}/pynvim-${PV}"
 
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.3.2-r1.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.3.2-r1.ebuild
new file mode 100644 (file)
index 0000000..52c62c1
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for Neovim"
+HOMEPAGE="https://github.com/neovim/pynvim"
+SRC_URI="https://github.com/neovim/pynvim/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+       dev-python/msgpack[${PYTHON_USEDEP}]
+       virtual/python-greenlet[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)"
+
+RDEPEND="
+       ${DEPEND}
+       app-editors/neovim"
+
+S="${WORKDIR}/pynvim-${PV}"
+
+python_prepare_all() {
+       # allow useage of renamed msgpack
+       sed -i '/^msgpack/d' setup.py || die
+       distutils-r1_python_prepare_all
+}