sys-apps/zorroutils: bump up to 0.05
authorSergei Trofimovich <slyfox@gentoo.org>
Tue, 21 Apr 2020 20:05:32 +0000 (21:05 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Tue, 21 Apr 2020 20:05:36 +0000 (21:05 +0100)
Reported-by: Michał Górny
Closes: https://bugs.gentoo.org/696776
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-apps/zorroutils/Manifest
sys-apps/zorroutils/files/zorroutils-0.05-fix-build-system.patch [new file with mode: 0644]
sys-apps/zorroutils/zorroutils-0.05.ebuild [new file with mode: 0644]

index c35fb560fd29064a611f9a37b534d081e388673e..0150b6d219e481695d6e0c98ca8005d326abc176 100644 (file)
@@ -1 +1,2 @@
 DIST zorroutils-0.04.tar.gz 12205 BLAKE2B b5818073551b39d715c8e8fbaaba2b827a7a4f4442bac76876037721d1202cf5893779cd22fba0451d2a0e7eb15266b08af242a1fa1c6be3eff2e65949523803 SHA512 e00a621cc64f3c50ae940809eb79ee145dab7d042e5a2b7fafe14bc7f9f85ff2e1b592d8922e628c5dbcecab95e6bd634d0cbbc1cc84f72136a5235480e6274f
+DIST zorroutils-0.05.tar.gz 15428 BLAKE2B e9baa6de4da3cbc6754c52d9e0c1fe34ce735b4d5377772c1765bdd30ae988f92125a5f254fcaab797eed33d65dad59e2a385fba3fc4610a9cfb6c34c6b45e7e SHA512 5260cfc7ccf77d0a0fe012c32ab492824903cb0f1397a82cf4c52aa12df5845b9e3d53aa1f619cc3a0637dfb42e9b75f80d715e4e912c5b8f42e0588f9053421
diff --git a/sys-apps/zorroutils/files/zorroutils-0.05-fix-build-system.patch b/sys-apps/zorroutils/files/zorroutils-0.05-fix-build-system.patch
new file mode 100644 (file)
index 0000000..3b98111
--- /dev/null
@@ -0,0 +1,14 @@
+Respect user variables
+
+--- a/Makefile
++++ b/Makefile
+@@ -2,9 +2,5 @@
+ # Makefile for Linux Zorro Utilities
+ # Copyright (C) 1998--2000 Geert Uytterhoeven <geert@linux-m68k.org>
+-CC=gcc
+-OPT=-O3 -fomit-frame-pointer
+-CFLAGS+=$(OPT) -Wall
+-
+ PREFIX=/usr
diff --git a/sys-apps/zorroutils/zorroutils-0.05.ebuild b/sys-apps/zorroutils/zorroutils-0.05.ebuild
new file mode 100644 (file)
index 0000000..f5e28bc
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Zorro bus utility for Amigas running 2.1 and later kernels"
+HOMEPAGE="http://users.telenet.be/geertu/Download/#zorro"
+SRC_URI="https://github.com/glaubitz/zorroutils/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~m68k ~ppc"
+
+PATCHES=(
+       #"${FILESDIR}"/${PN}-0.04-20021014.diff
+       #"${FILESDIR}"/${PN}-gentoo.diff
+       "${FILESDIR}"/${PN}-0.05-fix-build-system.patch
+)
+
+src_configure() {
+       tc-export CC
+}
+
+src_install() {
+       dosbin lszorro
+       einstalldocs
+       doman *.8
+
+       insinto /usr/share/misc
+       doins zorro.ids
+}